Support » Localhost Installs » Logo image not loading after Permalink Settings change

  • Resolved bkuethen


    I just changed my permalink settings to
    and the logo url is now adopting the new permalink structure.

    What’s odd is the link is hard-coded and displayed correctly, but I get a 400 error and the image doesn’t load.

    I’m using the following code:

    <a id="logo" href="<?php echo get_option('home'); ?>/">
       <img src="wp-content/themes/Theme-Name/images/logo.png" alt="">

    But this is the url that is returned which errors out: http://localhost:8888/2013/07/blog-post-title/wp-content/themes/Theme-Name/images/logo.png

    It seems like this is an error, but maybe I’m doing something wrong in my code. It doesn’t seem like the url should include the month, year, and post title before hitting the wp-content/…

    One thing to note is that the logo loads perfectly fine on the index page.

    Any help would be greatly appreciated.

Viewing 1 replies (of 1 total)
  • Ha! Figured it out.

    I added the blog url home to the beginning of the img src which solved the problem.

    <img src="<?php echo get_option('home'); ?>/wp-content/themes/Revive-Responsive-2013/images/logo.png" alt="">

Viewing 1 replies (of 1 total)
  • The topic ‘Logo image not loading after Permalink Settings change’ is closed to new replies.