Support » Networking WordPress » login/?action=register says registration has been disabled

  • Hello Everyone,

    I’m going crazy here, I’ve spent the last 2 days trying to figure this out. I have a multi site setup, with s2member installed and free registration enabled in both the network admin s2member options and the main site s2member options. However everytime I try to test the link, it takes me to a page saying “Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.
    Registration has been disabled.” You can see for yourself here

    I have tried disabling several other plug ins. I have the security key setup in the s2member options. I tried updating to the very latest wordpress version, I uninstalled and reinstalled s2member, I disabled my cache plug in. Allow new user registration up until now was always set to disabled. I have the theme my login plugin, could that be causing conflicts? I am willing to bet there is some kind of conflict going on or some left over setting.

    The only thing I can think of is, in the past I tried installing different plug ins and I think I installed some that had to do with user access, similar to membership type plugins, so perhaps there is some other plugin, or since deactivated / deleted plug in that has left it’s settings in my code or in my database not allowing new user registration.

    What’s worse, when I try that link from one of my sites on the network it redirects me to the main site on the network as well. It redirecting to the main site should hopefully provide more clues as to what’s going on. Regardless of the new user registration not working even when everything is set to enabled it shouldn’t be redirecting me to my main network site. So for example redirects me to which is my main site.

    I have searched for hours on google, the wordpress forums and the forums on s2member’s website. I have read every possible related post I could find, but none seem to be the same problem I’m having.

    Please somebody, HELP ME! I’m dead in the water until I can get this figured out.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Have you checked to make sure that you don’t have user registration disabled in your site options? Go to Network Admin -> Settings -> Network Settings and look under the “Registration Settings” header to make sure you have it set to either “User accounts may be registered” or “Both sites and user accounts can be registered.”

    Yes, it was set to user accounts may be registered. Could it be some kind of past membership plug in that has since been deleted but could have left some of it’s settings, because in the past I always had every option always set to not allow registration?

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress is where the registration link should be redirecting to.

    Are you usre you looked in the NETWORK settings and not the main site’s settings? (check there too)

    yes I looked in the network settings AND the main site’s settings. I have enabled new user signups in s2member as well. Over on the s2member forums they had me try which works, but that isn’t the default link that should be working. So it’s a big help, but if wordpress is by default sending people to the link that doesn’t allow them to register, then even though this other link works, it won’t do me much good.

    Perhaps this has something to do with it… I believe I had installed members (not wp-members), and in this plugin there is an option that says “Enable the role manager.

    Your roles and capabilities will not revert back to their previous settings after deactivating or uninstalling this plugin, so use this feature wisely.”

    I re installed this plugin today, and that option was already checked. So, does anyone know if this might be the problem and if so, how I can undo the changes this option creates?

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Your roles and capabilities will not revert back to their previous settings after deactivating or uninstalling this plugin,

    Yeah talk to the plugin dev to see how to undo that.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘login/?action=register says registration has been disabled’ is closed to new replies.