Support » Plugin: Instant Articles for WP » “Login with Facebook” unable to finish it’s task

  • Jer Clarke

    (@jeremyclarke)


    When setting up the plugin I am getting totally stuck at the “Login with Facebook” step, after successfully getting my “app connected” and before being able to “select your page”.

    WHAT I EXPECT

    * Push the blue “Login with Facebook” button.
    * Facebook opens and asks for my permissions.
    * Click to grant permissions
    * Be taken back to my wp-admin
    * See new options to “select your page” or whatever comes next.

    WHAT HAPPENS INSTEAD

    * Push blue button
    * FB opens as expected, asks to grant permission, I consent.
    * Go back to WP Instant Articles options.
    * Screen looks exactly the same as before. Blue button that I already pushed is still there, no new UI visible.
    * Clicking button again does basically nothing. The grey overlay appears, the spinner spins, then it dissappears and leaves the blue button showing with no effect.

    So IMHO something is wrong in the step AFTER the FB authentication happens, because it does let me authenticate the first time, but then gets stuck when it returns and is supposed to have the authentication token or something.

    OTHER DETAILS
    * Nginx + PHP7 + Ubuntu 16.04 + MariaDB
    * Tried both with and without Redis object caching (and tried removing all IA settings from DB and restarting, also tried several sites and one site with no other plugins active).
    * Looked through PHP/Nginx error logs and found nothing.

    OTHER USERS

    Please confirm if this is happening to you or not. Have you gone through this process with a recent and gotten past the blue button?

    If you are also stuck here please reply!

    DEVELOPERS

    What can I do next?

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘“Login with Facebook” unable to finish it’s task’ is closed to new replies.