WordPress.org

Support

Support » Plugins and Hacks » Login With Ajax » [Resolved] Login with Ajax Broken

[Resolved] Login with Ajax Broken

Viewing 15 replies - 1 through 15 (of 23 total)
  • Dear All,

    In addition to the above…. I tried the solution mentioned on another post of deactivating and reactivating the plugin, which for me did not work.

    I’ve removed the widgets from my sidebars, deleted the plugin files and then reinstalled. This does seem to work, but if I change any of the settings of the plugin or in the widget, it will break.

    “Breaking” in this instance means that any pages with the LwA widget in the sidebar will refuse to load (blank white screen results).

    When I leave settings alone and the plugin “works”, I’ve noticed that refresh times for the current page are very long compared to the last version.

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    Do you have a sample link for us to see?

    I don’t think the page load times would have anything to do with LWA though… does the speed improve if you disable the plugin?

    Hi Marcus,

    Thanks for the response. My page is http://www.chasingrays.co.uk – I’ve left things in the “working” state for now, but if you’d like me to “break” things for further testing, please let me know…

    Look on the blog page for testign – there’s no sidebar on the main page.

    Sorry for the confused explanation. The page load speed is fine. It’s when I enter my login credentials and LwA requests a page refresh, this seems to take a lot longer than previous versions of LwA (I am perhaps being a bit too picky here – I’m not so worried about this last issue unless it’s of any interest to you).

    Thanks,
    SD.

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    I tried registering account ‘testing’ for testing, but never got an email. I’d need to see it ‘broken’ to understand the problem really..

    Also, any examples on what exactly you change to break the plugin would help too.

    One thing you may want to try is switching themes temporarily. I have a feeling it’s a theme JS issue.

    I was having the same problem and I have solved it. I had one login-box on my page which I duplicated (cloned) (with jQuery) to another position. That way I got issues like the above. When I moved the login-box (instead of cloning it) I didn’t have any issues. My guess is it could have something to do with duplicate ID’s in the HTML…?

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    actually, 3.1 should allow multiple login widgets on the same page (will be putting up a demo soon)

    could it be because you have a custom widget template? If so then that may be the problem.

    Hi:

    I like the new redirects, however, I use your shortcode and it is displaying the following PHP errors:

    Warning: Missing argument 2 for shortcode_atts(), called in /…/wp-content/plugins/login-with-ajax/login-with-ajax.php on line 390 and defined in /…/wp-includes/shortcodes.php on line 294

    Warning: Invalid argument supplied for foreach() in /…/wp-includes/shortcodes.php on line 297

    An update to correct these would be great.

    Best Regards.

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    I’ve just updated the dev version to correct this, and also the broken JS problem (well, at least it degrades and doesn’t go blank)

    3.1.0.1 – http://downloads.wordpress.org/plugin/login-with-ajax.zip

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    I’ll be updating the plugin again shortly to a ‘stable’, but if you have time to test and confirm, that’d be appreciated!

    Hello Marcus,

    Looks like this problem is solved now….. I will try your link above to the corrected version ASAP and let you know what happens, though.

    I have authorised your account request to my site if you want to have a further poke around. I’m not sure why you didn’t get your email; captured as spam somewhere perhaps?

    To “break” the plugin just meant changing *any* setting – either through “dashboard >> settings >> login with Ajax” or in the LwA widget – and saving. This would result in blank screens on any subsequent page that used the sidebar widget in any browser I tried.

    Again, I’ll see what happens with your corrected version and get back to you. If it doesn’t work, I’ll leave the site in “broken” state and send another reply on this post.

    Thanks everyone for your comments on this thread – your help is very much appreciated.

    I can confirm this error. After updating to 3.1 version on 2 different blogs I couldn’t log in. All I get is {“result”:true,”message”:”Login Successful, redirecting…”,”action”:”login”}

    sorry, I have just noticed a newer version 3.1.0.1 – this one works, many thanks.

    A Global Login Redirect doesn’t work any more. I downloaded new files and now trying to set the plugin how it was before. Doesn’t matter what I put in the Global Login Redirect field, it always logs me in /wp-admin.

    Hello Marcus,

    Just a further note that I’ve tested version 3.1.0.1 and it seems to work fine. I can save changed settings and everything seems to be robust again.

    Thanks very much for the help and fix.

    SD.

    I’m marking this up as resolved – if anyone objects, let me know.

    Cheers,
    SD.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] Login with Ajax Broken’ is closed to new replies.
Skip to toolbar