Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Login Required for Posts Page

  • How can I put the Posts Page behind the Ultimate Member login functionality? From the dashboard, under the posts tab, I am in my ‘posts page’ (entitled “lessons” for my site). The “Restrict access to this content?” box is checked. “Who can access this content?” is set to “logged in users”. Navigating to my lessons page I can access the content while I am completely unauthenticated. I have used a separate browser entirely to make sure credentials weren’t cached.

    I can get other pages to behave appropriately using the plug-in. Just not the posts page.

    • This topic was modified 1 month, 1 week ago by  jefffabiny.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Asif

    (@cryptex_vinci)

    Hi @jefffabiny

    Follow these steps:

    1. Go to Ultimate member > Settings
    2. Click on Access tab
    3. Check the post tick-box from “Restricted Access to Post”
    4. Click on Save Changes.

    Thanks

    Thanks for the reply. This doesn’t seem to work for me. I have checked every box under the access tab, and an unauthenticated user can still see the posts page. I’m linking a screenshot of my settings: https://imgur.com/a/3Lp5F7N

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @jefffabiny,

    What version of the Ultimate member you have installed on your site?
    Do you have a caching plugin or server side caching active on your server?
    Please purge your cache and see if it helps.

    This issue can be also caused by some conflicts with your theme or other plugins so you can do a quick conflict test and see if this issue goes away.
    Here is the doc on how to do a conflict test if you are not sure how to do it.

    Regards.

    jefffabiny

    (@jefffabiny)

    I have Version 2.0.38

    I have no caching plugins.

    jefffabiny

    (@jefffabiny)

    I have created a separate, completely vanilla wordpress install, with no customizations at all. I added a new ‘lessons’ page, and set it as the posts page. I installed the ultimate member plugin. In settings I have ticked the box “restrict access to post”. From the ‘lessons’ page, I have set restricted access to that content to logged in users. From a separate browser with no login credentials possibly cached, I can access the ‘lessons’ page. This seems to be an issue with the plugin, not a conflict.

    jefffabiny

    (@jefffabiny)

    Is there any update to this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.