Support » Plugin: User Registration & User Profile - Profile Builder » Login redirect not working

  • Resolved vdugar

    (@vdugar)


    [wppb-login redirect_url="https://makephotomemories.com/"] exists in a Popup Maker popup. The login works but it does not redirect. Any advice besides disabling other plugins? Thank you.

    • This topic was modified 4 months, 3 weeks ago by vdugar.
    • This topic was modified 4 months, 3 weeks ago by vdugar.
    • This topic was modified 4 months, 3 weeks ago by vdugar.
    • This topic was modified 4 months, 3 weeks ago by vdugar.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi @vdugar

    Sorry, but we have no advice for this, other than not using the popup.

    The redirection happens inside the popup, that’s how it is.

    With best regards,
    Gabriel

    Thanks. I tried the shortcode on a “my-login” page (no popup) and it doesn’t work there either. Theme is GeneratePress. Same result with Astra theme. Bummer.

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hello @vdugar

    On this page:

    https://www.cozmoslabs.com/docs/profile-builder-2/shortcodes/#Redirect_users_after_Login

    it says

    The redirect will NOT work if it’s pointing to an outside URL, it needs to point to a page on your site

    Are you sure that you are taking it into consideration? It must be the exact same domain, please also pay attention to http vs https and wighout www vs with www

    Thank you, but why would a login form try to redirect to an outside URL? Of course it’s not. I’ve tried combinations of http:// -- https:// -- https://www… and none of them redirect from my login page. If I get this to work, I’ll go back to trying it in a popup form. BUT the logout_redirect_url works! Again, here’s the login page shortcode

    [wppb-login redirect_url="https://makephotomemories.com logout_redirect_url="https://makephotomemories.com/logout-msg"]

    The site is not live yet so the links won’t work for you.
    I also tried redirect_url="https://makephotomemories.com/home" which is valid.

    • This reply was modified 4 months, 2 weeks ago by vdugar.

    Turning off some plugins — no luck yet. So strange that the login works and the logout redirect — just not the login redirect.

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi @vdugar

    Yes, indeed, a full conflict test is the next recommended step:

    ​​*Briefly* disable all other plugins and enable the default Twenty Twenty theme. Please also disable all add-ons. If this fixes the problem, as it probably will, enable everything one by one, checking each time to see when the problem returns.

    Please let us know when you find the conflict so that we can take a look and see what we can do about it.

    Also, I have a question: when you say that the redirection does not work? What happens? Does it stay on the same front login end-page saying that you are logged in? Or does it go to the back-end?

    With best of regards,
    Gabriel

    Gabriel, I will get back to this (debug) soon, but to answer your question, the login stays on the front-end — on the same ‘/my-login’ page where the shortcode lives. I can give you access via the ‘Temporary Login Without Password’ plugin if you wish — I’d need your email address. Or can wait till I get back to this, hopefully tomorrow.

    Your question made me think a bit more, and I thought this might be the problem… I’m using the “WPS Hide Login” plugin which claims “The wp-admin directory and wp-login.php page become inaccessible”. You use it to create a custom login URL. However, I just disabled it (without removing it) and the problem remains. Back to the drawing board.

    • This reply was modified 4 months, 2 weeks ago by vdugar.

    I just deactivated all plugins except profile-builder and got the same result (login redirect not going to redirect_url in the shortcode). Then I changed theme from GeneratePress to Astra and that did not help. I guess I can try the Twenty Twenty theme but haven’t yet.

    Note that this is what appears in Chrome URL bar after login…
    https://makephotomemories.com/my-login/?request_form_location=page

    To quickly disable plugins it’s cool to use the WordPress CLI (command line interface) which is pre-loaded on my SiteGround shared host via SSH.

    Example:
    Create a list of enabled plugins and write it to a file…
    $ wp plugin list –status=active –format=csv –field=name >> wp_plugins_active.txt
    Use the list to deactivate the plugins…
    $ wp plugin deactivate cat wp_plugins_active.txt

    Then you can quickly re-enable plugins with the same list…
    $ wp plugin activate cat wp_plugins_active.txt

    – Vince

    • This reply was modified 4 months, 1 week ago by vdugar.
    • This reply was modified 4 months, 1 week ago by vdugar.

    please delete this post (I can’t figure out how).
    Am learning markdown formatting (problem with backticks)!

    • This reply was modified 4 months, 1 week ago by vdugar.
    • This reply was modified 4 months, 1 week ago by vdugar.
    • This reply was modified 4 months, 1 week ago by vdugar.
    • This reply was modified 4 months, 1 week ago by vdugar.
    • This reply was modified 4 months, 1 week ago by vdugar.
    • This reply was modified 4 months, 1 week ago by vdugar.
    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi @vdugar

    I don’t think that we have permissions to delete posts, perhaps only moderators do…

    Anyway, it’s really strange that you are getting this behavior even with all the plugins deactivated and another theme.

    In this case, here is the next recommended step. This test might take 5 or 10 minutes of your time, but it will be *very* helpful.

    Please install a fresh WordPress in a subdirectory of your current install, leaving everything as it is, all the settings on default.

    Then install and activate only our plugin, again with all settings on default, making only the changes that are absolutely necessary.

    Does the problem reproduce or not?

    Please let me know so that I can return with further instructions depending on the answer.

    With best regards,
    Gabriel

    vdugar

    (@vdugar)

    Been busy but back now. Let me see if I can figure out how to do the sub-dir install and give it a shot. In the meantime, I did another deactivate of all plugins except profile-builder (it’s quick to do with the WordPress CLI and lists) — and I enabled the twenty twenty theme. But no cigar — got same result.

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hi @vdugar

    OK then, waiting for the result.

    Also, I have another idea for a possible cause. Please make sure that you are using the regular simple quotation marks and not some special characters.

    With best regards,
    Gabriel

    vdugar

    (@vdugar)

    Partial success! Good call, Gabriel, on the quote marks. I am using the standard (“) double-quote marks but was **missing one** at the end of the redirect_url in the shortcode on the /my-login/ page! (see above) I’m a retired programmer (C, Java, JavaScript) and know you can stare at code all day and miss stuff. Sorry for the rabbit chase.

    I’m not done, however, as the same shortcode in a popup form (Popup Maker plugin) logs-in but does not redirect. If I can’t get that to work, I can live with the page login.

    TLDR. . .
    My site is still not live (“Restrict site access to visitors who are logged in or allowed by IP address”) and I thought for sure that was the problem (the network trace in Chrome DevTools showed a 403 error when accessing the redirect (home) page). I was “sure” because as soon as I opened up access (“Discourage search engines from indexing this site”) it started working (oh, that was the missing quote — by why the 403?). BUT then it **continued** to work after going back to restricted access. Hmmm.

    I know that caching can fool the debug process (at the host, at CloudFlare, and at the browser) — so I clear all caches when it makes sense.

    I’ll see what I can do to debug the popup approach. Thanks again. -V

    • This reply was modified 4 months ago by vdugar.
    vdugar

    (@vdugar)

    PS — The network trace shows a lot of . . ./wp-content/bower_components/. . . 404 errors. I don’t know what bower_components is. There is no bower_components dir in the wp-content dir (nor above it) on my server.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.