Login redirect error on 2.0 (30 posts)

  1. ericmcgregor
    Posted 9 years ago #

    I have installed wordpress a million times and I have never had this happen before. This is a fresh install of wordpress 2.0, and when I try to login all it does is redirect me to the login page. Does anybody have any idea why this is happening or how to fix it. I have 2.0 running locally on my mac and it works just fine.


  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I just logged in.

    Clear cache / cookies ?

  3. whooami
    Posted 9 years ago #

    works for me, I even posted :P

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    LOL :)

    I saw !

  5. whooami
    Posted 9 years ago #

    actually I owe him a thanks, since Ive not meandered over to the .com site to see what 2.0 actually looks like in the backend. Now I know, and am even happier to keep what I have :) ajax, and that damn MS Word-ish toolbar arent good enough reasons for me to upgrade..

    So thanks!!

  6. And rather than post something nice, you decided to spam your blog's URL? :|

  7. ericmcgregor
    Posted 9 years ago #

    wow. That's great you guys. I still can't get in. heh. Maybe you guys can just blog for me. christ.

  8. Oh, works fine here too.

    Anyway, try a different browser? Delete all cookies and crap as said?

  9. whooami
    Posted 9 years ago #

    Im using ff 1.07, eric, close your browser, delete ALL your cookies and your cache, and then give it another go..

    oh and viper, yeah.. I save all my "nice" posts for my own blog.

  10. ericmcgregor
    Posted 9 years ago #

    Thanks. ;)

  11. HeavenlyEvil
    Posted 9 years ago #

    Clearing the browser cache is not enough. You need to clear the wordpress 2.0 cache in your wp-content folder.

  12. giggy
    Posted 9 years ago #

    I also have to same problem of WP2.0 keeping asking for a login information after it gave me id=admin and password=self-generated and I followed exactly the same.

    Hours passed and I even uninstalled and reinstalled and it's the same.

    Please, let me login! I need to administer for the first time! Arh.....

  13. giggy
    Posted 9 years ago #

    As was suggested by Evil, I also cleared cache in wp-content folder...but to no avail.

    Why do I keep getting the same asking of login information prohibiting me from administering for the first time?

    If I put a wrong password and click to retrieve password, it replies on a blank page, "The e-mail could not be sent.
    Possible reason: your host may have disabled the mail() function..."

    Is it then related to my(host server's) email function that WP2.0 keeps asking for a login after the fresh installation?

  14. giggy
    Posted 9 years ago #

    Is there anyone who could help me with finishing installation at the last moment?


  15. patis
    Posted 9 years ago #

    Just to tell you that I'm on the same boat. Fresh install of 2.0.1 under Linux (Ubuntu). Clicking "Login" on the login page doesn't take me anywhere but to the same page.

    So far I've been unable to login at all to WP :(

  16. giggy
    Posted 9 years ago #

    I don't know what to say. Nobody seems to have any idea including the developers.

    I just have to delete WP and install other CM software.
    Well, I think I have to further research what other software is feasible. Oh well...Good luck to your WP.


  17. giggy
    Posted 9 years ago #

    I reinstalled and this time the login led me to a directory structure (the page where you see all the directories when a web page cannot be found). And it happened to some other links in the index.php page as well.

    And then after about 5 minutes later, All the links came back to normal but the login redirect error came back as well!

    Anyone has any idea what went wrong?

    Windows 2003 server, MySQL 5.., PHP 5.., Database is working fine. I have no other database.

  18. giggy
    Posted 9 years ago #

    Submitting comment also redirecting back to the commenting page...leaving no comment I just made.

    What's the typical cause for this kind of behavior?

  19. giggy
    Posted 9 years ago #

    Now I believe the 2.0.1 updated version "will" fix my problem with redirecting to login. Let me try this new version and I'll let you know.

  20. giggy
    Posted 9 years ago #


    The updated 2.0.1 didn't fix the problem.

    I'm stuck now.

  21. giggy
    Posted 9 years ago #


    It is working...at least from my notebook!

    On my notebook, I lowered my security setting to minimum for my site and register it as Trusted Site. I now have access.

    But it didn't work from my desktop even if I did the same as my notebook, lowering to the minimum security setting and registered as Trusted Site.

    Window's firewall is disabled on both computer.

    Any ideas?

  22. ManuelViloria
    Posted 9 years ago #

    Hi! I experienced the same thing when I set my website URI to domainname.com/index.php

    To solve it, I edited the contents of the mySQL database: wp_options - siteurl and erased the "/index.php" part.

    And that solved my login redirect error.

  23. giggy
    Posted 9 years ago #

    Well...I don't have the "/index.php" part...or the trailing slash...

  24. ManuelViloria
    Posted 9 years ago #

    What value is stored in your wp_options-siteurl?

  25. jazzmansblog
    Posted 9 years ago #

    I was experiencing the same problem. I tried ManuelViloria's suggestion and it worked for me.

    Here is how I did it:

    Through my cpanel, I went to phpMyAdmin.

    On the left sidebar, I selected the blog database in question from the drop down menu.

    Below that will appear the database structure. I clicked the wp_options link.

    At the top of the wp_options page, I clicked the Browse button.

    I then clicked the edit icon for the siteurl line, and edited the option_value to the correct login directory.

    Hope this helps.


  26. Hiromi-chan
    Posted 9 years ago #

    Hello everybody!
    My wordpress installation worked perfectly till last night. No problem whatsoever. For somereason last night I couldn't logout, and this morning I couldn't login anymore. I am always redirected to: /wordpress/wp-login.php?redirect_to=%2Fwordpress%2Fwp-admin%2F
    content/cache has been emptied several times and I've already resetted the password from phpmyadmin. My wp_options-siteurl is set to http://www.nopressure.co.uk/wordpress/ .
    Really can't figure this out and I've already tried from other pc @ home.........

  27. Laurie76
    Posted 9 years ago #

    Had the same thing after an upgrade to 2.0.4. Always a redirect to those weird extended urls. I could copy the shortcut by a right click and paste then it would work. FINALLY, cleared all cache from IE, cleared all cookies, shut down all IE browsers, opened IE, then all links were back to normal. Your mileage may vary.


  28. frankj
    Posted 8 years ago #


    I have found what the issue is with this:

    1) You may have added this site to the "blocked cookie list" - delete it from there
    IE: tools > internet options > privacy > sites > look under managed sites
    If your site is there, delete it

    2) Make sure your browser is accepting cookies for this site
    Between the login and the re-direct to the correct admin page it seems like WP reads
    the cookie, if it ain't there, it will just redirect to the wp-admin page again
    IE: tools > internet options > privacy > sites > in address of website type your
    url with http:// in front and click "allow"

    3) Test by setting your security level to low.
    IE: tools > internet options > privacy > drag lever down to "accept all cookies"

    You may need to apply just 1 or all of them for it to work.

    Hope you get it working & God Bless

  29. macksimpson
    Posted 8 years ago #

    Like Hiromi-chan, above, I'm suddenly getting the same redirect problem.

    I've emptied the browser cache/cookies and completely reset it.

    I've killed the WP cache file.

    I've navigated through SQL and made sure the site URLs were correct.

    I've tried a new wp-login.php file.

    Nothing works.

    What is up with this? I haven't seen a good answer-- or solution-- yet.

  30. cbdilger
    Posted 8 years ago #

    I had the "redirect" problem as well, and the fix described in this thread solved it:


Topic Closed

This topic has been closed to new replies.

About this Topic