Support » Plugin: Memphis Documents Library » Login redirect

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author bhaldie

    (@bhaldie)

    currently no you can’t do that, if you want people to be able to download the file you will have to uncheck the option in the mdocs settings “Hide All Posts”. This will give users the ability to see the posts and be able to download the file.

    There are other options for this feature which include “Hide All Posts (Non Members)” and “Hide All Post From Homepage”

    I will add this to a feature list but currently the only option you have is what I stated above.

    Thanks for the quick response.

    So, how do I fix the issue of members who log in using mDocs to download the file but are redirected to the post page where it says they’re not able to download the file because they don’t have the right permission (they do once logged in)?

    Thanks.

    Plugin Author bhaldie

    (@bhaldie)

    If you goto mDocs Dashboard > Options > Settings > Post Options > uncheck “Hide All Posts”

    Thanks – that seems to do the trick.

    However, a new issue has come up. When I turned off “Hide all posts” and went back to the directory listing, the following error showed up in the first three columns: “” function does not exist.

    Also – in the Settings section, where you can decide which columns are shown, something weird is happening where multiple rows are being created with nothing in them and they keep replicating if I try turning off and on the “hide all posts” check box.

    Plugin Author bhaldie

    (@bhaldie)

    are you using the latest version of mDocs?

    if so you will need to run a cleanup script. Add this line to the mdocs-patches.php under line 2:

    
    function mdocs_run_patch() {
        update_option('mdocs-displayed-file-info', array());
    

    head to the dashboard and setting again and see if the problem has cleared. Once its been clear remove the line from the file.

    • This reply was modified 4 months, 1 week ago by bhaldie.

    Perfect. That worked like a charm. Many thanks!

    Plugin Author bhaldie

    (@bhaldie)

    glad its working now 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.