[resolved] Login Reauth Redirect on Subdomains (7 posts)

  1. Web Studio
    Posted 4 years ago #

    We've been banging our heads against the wall since we upgraded to 3.3.1.

    We have a medium sized network (30+ sites) and the login is no longer working on the subdomains.

    For example, we have http://www.ournetwork.com and we have several sites (www.site1.com, http://www.site2.com etc) that are mapped to subdomains on the network (www.site1.com = site1.ournetwork.com).

    Logging in at http://www.site1.com/wp-admin/ works without any problems. We are redirected to http://www.site1.com/wp-login.php and the clients can login.

    However, we have several sites taht don't have a top level domain name assigned to them and are only subdomains on the network (subdomain1.ournetwork.com, sub2.ournetwork.com etc...). We cannot login on those sites at all. Everytime we go to sub2.ournetwork.com/wp-admin/ we get redirected back to the wp-login.php page (which let's say is normal behaviour) and then when we enter the correct login credentials we are back on wp-login.php??redirect_to=...%2Fwp-admin%2F&reauth=1

    Any ideas ?

  2. What mapping plugin are you using?

  3. Web Studio
    Posted 4 years ago #

    This is the plugin:

    It was the first thing we tested and we disabled it and then deleted it from the plugins folder but the problem remained. This morning we were able to fix it.

    Your first guess and our first guess (the mapping plugin) was the thing that had the problem. sunrise.php was being executed since it was directly in the wp-content folder. Turns out that doing the mapping for the subdomains fixes the problem, but the strange thing is that we never had to do that before. Previously it was working without the mapping for the subdomains and we were using the mapping only for the top level domain names we had.

    Anyways, entering the subdomain mapping data in the plugin fixed the problem and it's all ok now. We can close this topic.

  4. Grab the dev version of that plugin - http://downloads.wordpress.org/plugin/wordpress-mu-domain-mapping.zip

    See if that works better?

  5. Doublecheck someone didn't muck up your wildcard subdomain record.

  6. lernerconsulting
    Posted 4 years ago #

    Web Studio, I'm not clear, what did you do that worked? I have the dev version of the plugin, 1/7/2012, and get the login loop you had.

  7. Web Studio
    Posted 4 years ago #

    Hi !
    Previously we had several subdomains (subdomain1.maindomain.com) and a few top level domains (domain1.com, domain2.com etc). In the mapping plugin we had just those top level domains and the plugin code is doing checks for the URL in the DB. If you add the subdomains in the mapping database it should work.

    Basically just go to your domains mapping and start creating entries for each site that you have (site 2 should point to subdomain2.maindomain.com).

    This is what worked for us.

    PS. If there is a new dev version from January we didn't have that installed so i'm not sure if this will still work.

Topic Closed

This topic has been closed to new replies.

About this Topic