Login problems to main site (12 posts)

  1. scoopster35
    Posted 4 years ago #

    Hi, used the Enable Multi-Site plugin, which has worked well.
    Except, now I can't log in to my main site and therefore can't add extra plugins etc or modify my original site.
    I have changed my login to the site, I know it is right, but every time I log in it sends me back to the admin page and prompts me to add the password again. And so on and so on.
    Is this a common problem and is there a way round it>

  2. scoopster35
    Posted 4 years ago #

    I can log in to my subdirectory multisite, but should I try to access My Sites and go into the dashboard I get sent to the login for the main site and from there I can't log in to the main site
    Frustrating man

  3. Hi, used the Enable Multi-Site plugin, which has worked well.

    Using that isn't supported, nor recommended by most of us.

    Remove it. Undo whatever it did.

    Create a Network manually. It's good practice for what life is like supporting Multisite.

  4. scoopster35
    Posted 4 years ago #

    I did it before I realised how easy it is to create a network. I'll see if I can remove it. Just means it's a bugger to back up galleries of pictures as I lose my galleries when exporting my files.

  5. You don't have to export anything. Just uninstall the plugin, and then restore your wp-config and .htaccess from backup (which you hopefully have...)

  6. scoopster35
    Posted 4 years ago #

    Done that
    Back down to my one site, which I can now gain access to.
    But, following this http://codex.wordpress.org/Create_A_Network I have added the necessary line to wp-config and I can't get to stage 3. Nothing happens. Just normal dashboard comes up.
    This is what I have in the top section of my wp-config file.
    Is it in the right order?

     * The base configurations of the WordPress.
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     * @package WordPress
    <strong>define('WP_ALLOW_MULTISITE', true);</strong><em>
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'XXX');
    /** MySQL database username */
    define('DB_USER', 'XXX');
    /** MySQL database password */
    define('DB_PASSWORD', 'XXX');
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    Any help appreciated to get out of this mess, although am getting out of it sort of :)

  7. Order doesn't matter TOO much, but I always put it at the end, below the debug line.

  8. scoopster35
    Posted 4 years ago #

    Right, but that should work should it?

  9. That's PART of it.

    You did step 2 - http://codex.wordpress.org/Create_A_Network#Step_2:_Allow_Multisite

    Now follow the rest of the directions.

  10. scoopster35
    Posted 4 years ago #

    :) Cheers pal

  11. scoopster35
    Posted 4 years ago #

    I have got the same problem as above back with my new install of multisite. Maybe there is something I didn't clear out of the system when I took out Enable Multi-site, but again I can log into my subsite by not my main site.
    I get this as I login and keep getting redirected


    Is there something wrong here do you know?

  12. If you were able to MAKE a subsite, then everything worked fine at one point, right?

    What did you change right before it stopped? Did you add new plugins in?

    Have you tried renaming the plugins folder to plugins-old?

Topic Closed

This topic has been closed to new replies.

About this Topic