Support » Plugin: Affiliates Manager » Login Problem – Custom slug – 404 error

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support mbrsolution


    Hi, did you add the correct shortcode per page you created? Can you enable Debug mode and check the log files after you log in. Then check the log files and report back. I am curious to know what the log files say.

    Thank you

    Shortcodes are intact. I’m just renamed slugs. Of course, it looks like this:

    Home Page > [AffiliatesHome]
    Registration Page > [AffiliatesRegister]
    Login Page > [AffiliatesLogin]

    I have enabled debug. Then I was logged in as a affiliate. Then, in a different browser I was logged in as an administrator. But … wpam-log.txt is empty.

    I do not know what the problem is. I have tried this on 3 pages, of which 2 online, and one is on localhost with XAMPP. The problem is the same everywhere.

    Something in the plugin redirect to “/affiliate-home/” (default slug).

    In fact, to explain. Affiliate (logged) comes to the “/affiliate-home/” and that is a page that does not exist. In fact, the affiliate is logged into his affiliate account. But affiliates see page 404. This is the first page that he sees. The problem is that I know. But many people do not know.

    I am sure that this would be all right if I come back slug in English. But I have all translated. This is not a problem for me but it is a big problem for my customers.

    I am sure that the problem is not on my side. I have checked everything.

    Do you have any idea?

    If you think it’s necessary I can send you login credentials. But I’m sure if you on your side temporarily change your slugs (eg /affiliate-home/ into /affiliate-area/), it will be the same problem that I describe.


    Plugin Support mbrsolution


    Hi you mentioned the following.

    Shortcodes are intact. I’m just renamed slugs.

    Did you also create the pages for each renamed slug?

    For example.

    Home Page:
    Did you create the following page Affiliate Partners?

    Registration Page:
    Did you create the following page Aff Register? Also this page has a parent page Affiliate Partners.

    Login Page:
    Did you create the following page Aff Login? Also this page has a parent page Affiliate Partners.

    Yes, of course. Exactly in this way.

    Plugin Support mbrsolution


    Did you also clear your cache if have a cache plugin? Did you also clear your browser cache?

    Yes, it’s all done (Comet Cache and Autoptimize – purged, Firefox – cleared). I mentioned before. I repeat that there is no fault on my side. I have experienced with WP. Well, I understand that you’re trying to eliminate any possibility. But it’s all right, several times checked.

    Plugin Support mbrsolution


    Thank you for reporting and providing all the extra information. This will help the plugin developers troubleshoot your issue further.


    Thank you very much. Thanks in advance.


    Plugin Author affmngr


    @vipteam, These are just example pages. Can you please share the actual links so I can investigate this?

    After creating these new pages did you update the URLs in the settings (Affiliates > Settings > Pages/Forms)?

    @affmngr, Of course, the settings are updated. Moreover, I updated permalinks. I tried everything that was possible.

    Unfortunately, I can not provide a link to the public. But, I can send you a link with a temporary login credentials, full administrator access.

    Which email address that I send this? Or via the contact form on

    Thanks in advance. Regards,


    1. I’ve made a complete new website with only one purpose – testing WP Affiliates Manager. Only one plugin, only 4 (home and affiliate) pages, default wp theme. Nothing more.

    I am very angry because this is your job. It’s not my job to test whether the plugin works or does not work. Two days in our correspondence. Nobody reads. No one wants to admit his mistake.

    2. Of course, as I suspected, as I previously wrote, even hinted that cause – and now I’ve proved. The problem is on your side. Because of your mistakes.

    3. Affiliate Home Page does not accept any changes. “/affiliate-home/” must still be “/affiliate-home/”.

    … we have just released an update that includes this feature.

    – This statement is not true! SOURCE:

    Scenario #1

    Home Page: (WORKS)
    Registration Page: (WORKS)
    Login Page: (WORKS)

    Scenario #2

    Home Page: (ERROR)
    Registration Page: (WORKS)
    Login Page: (WORKS)

    Visitor normally register as an affiliate. After receiving the message, he clicks on the link to login. 404 page. Of course, because the plugin redirect on “/affiliate-home/”.

    You have not tested the plugin after new features (pages/forms). You did not change the way the plugin should work. Before there was only one option. And now there’s only this option does not allow changes.

    I hope you understand what I’m saying.

    Want to test it? Okay, go here:


    Done. Thanks in advance.


    Problem resolved in v2.4.0

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator


    Nuts. Now I’ll have to review all 164 replies…

    @affmngr I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Login Problem – Custom slug – 404 error’ is closed to new replies.