WordPress.org

Forums

  1. sadler.oliver
    Member
    Posted 1 year ago #

    In one of my websites where I am using your plugin, on enabling hide login area and creating a custom slug for the login page, the login page gets lost and gives 404 error. If the option is disabled, it works fine on default login url as "wp-admin"

    Have you come across this issue elsewhere, please provide your guidance to fix this.

    https://wordpress.org/plugins/better-wp-security/

  2. Sunthing
    Member
    Posted 1 year ago #

    I have the same issue. Register, login, and password reset are all broken if Hide Backend is active. This is on nginx.

  3. Michele Butcher
    Member
    Posted 1 year ago #

    When you use the hide login area you have to use the slug you generated instead of the wp-admin slug. When it is enabled it will throw a 404 for all the default WordPress slugs.

  4. Viktor Nagornyy
    Member
    Posted 1 year ago #

    Just had an issue with this on the clients site, fixed it just few minutes ago.

    For whatever reason, it wasn't working. I had to reset hide backend feature through database.

    Inside _options table, you need to find option called itsec_hide_backend. Update the value to a:0:{} and save. This will turn your hide backend feature off. Go back in and re-enable it, and it should work. Works on our end.

  5. sadler.oliver
    Member
    Posted 1 year ago #

    @: m_butcher: The slug created was the one that was being used. But it still was giving that 404 page error. When disabling the feature, it took me to the login page.

    @: Viktor Nagornyy: I did what you had recommended. But when going back and activating the feature, the values get updated to the same again.

    * Solution Worked for ME: Delete and Re-Install plugin. Activate the option again. It worked. Though you will have to rework on other security settings as well.

  6. Viktor Nagornyy
    Member
    Posted 1 year ago #

    Mark it as resolved :)

  7. lomars
    Member
    Posted 1 year ago #

    Helo,

    An alternative solution, is to open the .htaccess file with write mode enable (CHMOD 644 or permissions: rw-r--r--) and erase temporaly :

    `
    # BEGIN Hide Backend
    # Rules to hide the dashboard
    RewriteRule ^/xxxxxxxxxxx/?$ /wp-login.php [QSA,L]

    # END Hide Backend
    `

    xxxxxxxxxxx is the slug you have used instead of wp-admin or login.php

    i hope that will help other people also

    L..

  8. Viktor Nagornyy
    Member
    Posted 1 year ago #

    It will not disable hide backend feature by simply removing the rewrite. New plugin uses database option for the rewrite as I can tell. Removing it does not disable it in my tests.

  9. lomars
    Member
    Posted 1 year ago #

    Hello Viktor

    Yes it will.
    For this feature, in the database you have only the saved setting, and this take effect in the .htaccess file.

    This is my experience and my opinion. Only the dev of this plugin is the one who can really confirm or not what i am saying.

    Have a nice night

    L..

  10. Michele Butcher
    Member
    Posted 12 months ago #

    Please mark this thread as resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic