Support » Plugin: Login With Ajax » Login page failed

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Marcus

    (@netweblogic)

    Hi, sorry for the late reply.

    Have you tried without LWA enabled? It sounds like another plugin might be preventing LWA from working here, most likely a security plugin of some kind.

    You can also check with other plugins disabled just for yourself using my WP Safe Mode plugin.

    Thanks for your answer.
    I tried in Safe Mode (Thanks for this really great plugin specially for multisite installation).
    When “Login with Ajax” is disabled, everything is OK.
    When “Login with Ajax” is enabled, the issue still happens.

    On the blog that I used to try, I disabled every plugin excepted “Login with Ajax” and “WP Safe Mode” and the issue still appears.

    Thanks for help.

    Plugin Author Marcus

    (@netweblogic)

    The only other suggestions I may have is to check you don’t have any redirection set up in LWA, in case something there is triggering logouts. Also, it might be worth checking if you have a firewall of some kind (such as a WAF like cloudflare, sucuri, etc.) and if it is triggering blocks whilst LWA is active.

    Unfortunately, there’s little I can do here as we’re not allowed to request login info to see your site, it’s against the forum rules (we’ve been warned about doing this before). The only way I would have been able to debug this further is with login/ftp info. You’d need to hire a developer to take a closer look at this.

    Thanks. I have do some work this afternoon and I solve my problem.

    This is what I did :

    • I disabled “Login with Ajax” on the network ;
    • I activated LWA for all the sites with the plugin “Multisite Plugin Manager” ;
    • I changed the redirections (by default I put %LASTURL% but when the users tried to log in without the widget they didn’t see that they were logged ; so I put the blog URL – %BLOGURL% doesn’t work)

    And I wrote a post to explain how to set LWA if you don’t use a widget with a blog preset by myself.
    Here : https://blog.ac-lyon.fr/tutos/configurer-la-connexion-des-utilisateurs/

    Thanks for your help and thanks for LWA and WP Safe Mode. Both help !

    Plugin Author Marcus

    (@netweblogic)

    Thanks for your last message. I’ve just figured it out… it’s %LASTURL%

    Because you logged in from wp-login.php, LWA redirects you back to the login page each time 🙂

    I’ve just updated LWA with 3.1.10 with a fix for this so %LASTURL% is ignored if logging in from WP’s login page. Try again with %LASTURL%, it should work now.

    Marvelous 😉
    Thank you very much.
    Will it be possible when %LASTURL% is ignored to go home (the blog URL) and not the login page ?

    Plugin Author Marcus

    (@netweblogic)

    It’ll just ignore %LASTURL%, so the default will be to go to the dashboard. At the moment, this is the only alternative. Other URLs will work fine in wp-admin, just not %LASTURL%

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.