[resolved] Login not working, blank screen (2 posts)

  1. danlharp
    Posted 9 years ago #

    I maintain a blog for my sister at http://abbykingsbury.org/blog -- on Saturday, she emailed me that she was unable to post anything to her blog. I tried to login, typed in her username and password, and wound up with a blank screen at the URI "http://abbykingsbury.org/blog/wp-login.php".

    Since I hadn't yet upgraded this blog to 2.1.3, I figured I had nothing to lose by trying that first -- I followed the detailed upgrade instructions (except, of course, I couldn't deactivate plug-ins since I couldn't access wp-admin, though the only plug-ins activated are the Spam Karma, Akismet, and backup plugins). The upgrade appears to have been successful, except I still can't log in to the site.

    A few other factoids: (1) After reading http://wordpress.org/support/topic/97220 I looked at the theme. The blog uses a slightly modified Kubrick theme, but I uploaded a standard Kubrick theme via FTP into that folder just in case it was a problem with the theme. Didn't help. (2) After reading http://wordpress.org/support/topic/105933 I checked to see if the blank screen was a browser problem, tried both Firefox and Safari, but same results with both browsers. (3) When I try logging in with an incorrect username or an incorrect password, I get the expected wp-login.php screen telling me "Error: Invalid Username" or "Error: Incorrect password"; when I use the correct username and password, I get the blank screen. (4) Typing in "http://www.abbykingsbury.org/blog/wp-admin/" does not redirect to the login screen, it just gets a blank screen at the wp-admin URI. (5) After reading http://wordpress.org/support/topic/108657, I deleted plugins, but it didn't help (so I uploaded plugins again).

    Finally, the error log is full of entries like the following:

    [15-May-2007 16:11:10] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/abbyk/public_html/blog/wp-config.php:43) in /home/abbyk/public_html/blog/wp-login.php on line 12
    [15-May-2007 16:11:10] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/abbyk/public_html/blog/wp-config.php:43) in /home/abbyk/public_html/blog/wp-includes/pluggable.php on line 313

    However, I have already erased and reinstalled wp-config.php (I have not replace wp-includes yet, because if I'm getting errors for wp-config and that doesn't fix it...).

    Thanks in advance for any help and advice. Cheers, Dan.

  2. danlharp
    Posted 9 years ago #

    So after much additional work, and the full cooperation of my sister's Web host support staff (thanks, Dennis!), we finally determined that what brought the blog down was the fact that my sister had pasted a MS Word document directly into the blog. It appears that one or more of the invisible characters that Word embeds in its documents bollixed the MySQL databased and/or WordPress. We thought about trying to debug the problem, but after eight hours of work on my part, I was getting no closer to a solution. Unfortunately, we couldn't reinstall from a back-up, since the last back-up included the bollixed file. Instead, I installed a new blog in another folder, with a brand-spanking-new MySQL database, and put a redirect on the old blog.

    Moral of the story -- Word is well-known in among Web designers as producing destructive documents. Therefore, if you write your posts offline, do yourself a favor and use a text editor.

Topic Closed

This topic has been closed to new replies.

About this Topic