[resolved] Login loop when I try to login to new site (14 posts)

  1. adlbiz
    Posted 3 years ago #

    I have installed 3.5 multisite at godaddy in the root folder of thegalabouttown.com (site1, let's call it). I had no problem getting multisite enabled, and can get into site1 and post, add plugins, install themes, the works.

    My hope, however was to be able to use multisite to host several sites, each with their own distinct URL (site1.com, site2.com, etc.)

    However, when I create a second site (site2) astoriawhiskeysociety.thegalabouttown.com and then set the domain for this site as just astoriawhiskeysociety.com (registered with godaddy and pointing at the thegalabouttown.com root folder), I can't get in to the new site!

    When I try to go to the site2 dashboard I get a login screen that, when I enter my Super Admin name and password, resets and asks for it all over again. I've cleared cookies and ALL browser data, tried it in multiple browsers, and...blurg.

    I can create users for site2, but I just can't get into the dashboard.

    I've seen similar issues elsewhere in the forums, but I can't seem to find a fix. I would appreciate any guidance!

  2. Have you gone through everything here? http://halfelf.org/2012/multisite-login-loop/

  3. adlbiz
    Posted 3 years ago #

    Thank you for the link! I have tried those steps. Still the same problem. Annd when I add step 6 from that page I get an error:

    The constant "COOKIE_DOMAIN" is defined (probably in wp-config.php). Please remove or comment out that define() line.

  4. Right... Okay, what happens if you turn off domain mapping? Are you able to log in with astoriawhiskeysociety.thegalabouttown.com

  5. adlbiz
    Posted 3 years ago #

    If I turn off domain mapping (by disabling the plugin, yes?) then try to log in to astoriawhiskeysociety.thegalabouttown.com Chrome can't find the site:

    Oops! Google Chrome could not find astoriawhiskeysociety.thegalabouttown.com

  6. *heh* Well Okay, that's probably the real problem. The subdomain has to resolve if you wanna map it.

    Did you set up the subdomain and the DNS?

  7. adlbiz
    Posted 3 years ago #

    >gulp< I think I did. I set up astoriawhiskeysociety.com with Godaddy. It is a subdomain of thegalabouttown, pointed at that site's root.

    I CAN go to astoriawhiskeysociety.com... So that part is working.

    What do I need to do with the DNS?

  8. adlbiz
    Posted 3 years ago #

    It is also possible that "subdomain" in this case doesn't mean what I think it means!

  9. http://www.whatsmydns.net/#A/astoriawhiskeysociety.thegalabouttown.com

    That shouldn't be an X. Ask GoDaddy how to do that. :)

  10. adlbiz
    Posted 3 years ago #

    Hmm. that poses a problem I hadn't considered. So, I need to register all of my sitename.thegalabouttown.com domain names?

    Thank you for your help, by the way!

  11. You should be able to set up wildcard DNS routing.

    I certainly didn't make bibbeldy.ipstenu.org, but it works: http://www.whatsmydns.net/#A/bibbeldy.ipstenu.org

  12. adlbiz
    Posted 3 years ago #

    I've been able to set up astoriawhiskeysociety.thegalabouttown.com as a subdomain of thegalabouttown.com through my godaddy hosting. I even get the happy green checkmarks with whatsmydns.net Yet my loop persists.

    When I try and visit astoriawhiskeysociety.thegalabouttown.com I get a page that says only: pageok



  13. adlbiz
    Posted 3 years ago #

    Woo hoo! I figured it out, or at least by restarting the whole damn process I have it working. I think the problem was a sub-domains vs sub-directories conflict with godaddy. I am now using sub-directories.

    But now I have a NEW problem. I can get into the astoriawhiskeysociety.com dashboard, I can see the site, and it all works fine but when I try to "Visit Site" from within the dashboard it thinks the URL is com/astoriawhiskeysociety/astoriawhickeysociety/

    What have I done!?

  14. adlbiz
    Posted 3 years ago #

    Since this problem is new I'm going to start it in a new thread. Thank you for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic