Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Login / Logout options not working after upgrade to 2.0

  • Hi,

    I am finally testing UM 2.0 (2.0.16 to be precise).

    When a user with the role of ‘Member’ logs in via the UM login page he is directed to his profile page, despite the Login Option for members being to ‘Redirect to URL’ (http://dev.asbyparish.org.uk). Once logged in, any attempt to get to the site’s homepage results in this URL being formulated:
    http://dev.asbyparish.org.uk/user/geoffj/?redirect_to=http://dev.asbyparish.org.uk/
    – hence he simply finishes back on his profile page once more.

    When a user with the ‘Admin’ role logs in via the UM login page he is also redirected to his profile page, despite the Login Option for Admin users being set to ‘Redirect to WordPress Admin’. However,once logged in, he is able to get to the site’s homepage.

    Logging Out
    In all cases, when a user logs out via the UM logout page he is confronted with a blank page. This despite the fact that the Logout Option is set to ‘Goto Homepage’.

    NOTE All of this behaviour has only happened since moving from UM 1.3.88 to 2.0.16.

    • This topic was modified 1 year, 5 months ago by Tradewind25.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • I came here looking for a solution to the same problem. All social logins are redirecting to the profile page after a successful login. Direct user accounts (not social accounts) are handled as expected based on the settings for the role.

    I’m having a similar issue as well.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @tradewind25,

    It looks like a conflict with some plugin or maybe server side issue.
    We don’t have this issue on our several test sites.
    Can you please submit a new ticket on our website under the pre-release question section so we can add this ticket to our helpdesk support system and help you with this issue.

    Thanks.

    Hi. I too have this issue after upgrading to 2.0.17
    All user roles redirect to the user profile page regardless of the settings for the role. I have deactivated all other plugins and tested with TwentyFifteen theme and still the same issue?

    @ultimatemembersupport – the link you mention is headed “Pre-Purchase Questions”. This is NOT a sales matter- I have been using UM in Production for over 2 years.

    Given that other users have been reporting the same issue against this ticket it surely makes sense to continue with it. Should you wish to move iot another section of the forum for continued investigation then please do so.

    Note @mrtcryan’s update above.

    I have had this problem for 6 weeks now, and have received only useless responses from support, usually telling me to set up my client’s site the way it’s ALWAYS BEEN SET UP. It’s clearly a flaw with 2.0, but we were unable to successfully downgrade. We are still having to have our members-only section “open” until a workaround is found.

    Hi All,

    I have heard nothing from UM support on this but I believe I figured out the problem here.

    The issue is in the USER config. When I first installed UM my users were all set as SUBSCRIBERS for the main WP user role.. I then configured the UM role in the second drop-down below. This worked fine in the old version of UM and the redirect worked as expected, but since the upgrade to 2.0 the SUBSCRIBER role config takes priority. Hence ALL users begin redirected to the profile page

    I set all my users to the UM roles in the main role selector and now they work fine.. this image may help to explain a bit clearer!

    Hope this helps some of you with resolving this in your sites.. I know how frustrating this has been as I’ve just lost a week trying to figure this out!

    Thanks for the update. Glad you are sorted however I still have the problem as I reported in my initial post.

    Interestingly, under UM 2.0.17 I don’t have two possible places to set a user’s role. I simply have the first, as per your screenshot. (i.e. In the “Ultimate Member” section I simply have “Ultimate Member REST API”.)

    Previously, under UM 1.3.88 I could see “Community Role” under the Ultimate Member section. But as I say that has disappeared in version 2.0.17.

    COULD SOMEONE FROM UM SUPPORT PLEASE ADDRESS THIS ISSUE?

    Hi, I found this in the documentation:

    https://docs.ultimatemember.com/article/1328-new-roles-logic

    Not sure if this helps you but it looks like something has changed in the upgrade with Roles logic.. Do you have main site roles and UM roles which are named the same?

    Thanks for the link to that article.
    I have just read through it. Unfortunately the appalling English in which it is written has “done my head in”! Not going to attempt to try to interpret what it is trying to say on a Sunday evening. Will take another look tomorrow.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Login / Logout options not working after upgrade to 2.0’ is closed to new replies.