Support » Fixing WordPress » Login links not going to login page

  • Resolved moonshdw8

    (@moonshdw8)


    In my main menu I created a Custom menu item going to “/login/”.
    Whenever I click on it, I get redirected to the home page with the url “https://www.myhomepage.com/?login=failed&errcode=empty_username”.

    So it appears to be trying to automatically log me in, failing because the fields are empty, and then redirecting to the home page.

    I simply want the link to take me to the login page.

    If I copy and paste the link, it works fine.

    (using IIS 8.5, all version and plugins up to date. Multi-site installation. Child theme)

    Things I’ve tried:
    – changing the link to “/wp-admin”, “/wp-login.php”, tried the full url and relative url. all had the same result.
    – disabled all plugins
    – changed themes
    – added a menu link using code via functions.php. same result

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter moonshdw8

    (@moonshdw8)

    Just to make sure this wasn’t something relegated solely to the menu, I created a simple hyperlink on a page to go to the login page, and it too failed.

    Thread Starter moonshdw8

    (@moonshdw8)

    Fixed this if anyone else has the same problem. It was a plugin called “Sidebar Login Widget”.
    Even if the plugin was de-activated, it was automatically redirecting url references to the login page, back to the home page. Deleted the plugin and all was well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Login links not going to login page’ is closed to new replies.