• 4th_dimention

    (@4th_dimention)


    I am using iThemes Security for the first time. I tried using the hide backend option to hide the wp-login.php as hidden_login (for experimentation). Once I was logged out and trying to get in again hidden_login and wp-login.php both caused a page not found error. I got logged in again by taking the plugin files out directly, via ftp.

    Now what I need help with that I can’t find anywhere is how to make it work. Is there anyone familiar with this plugin who can help.

    I don’t know much about the .htaccess file, but it LOOKS like it should be setup correctly because it includes this:

    RewriteRule ^/bmg_admin/?$ /wp-login.php [QSA,L]

    I’m a bit confused on how this works and why I am not having success.

    https://wordpress.org/plugins/better-wp-security/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Freelance Web Developer

    (@freelance-web-developer)

    I am having this same issue. Any help is appreciated.

    Freelance Web Developer

    (@freelance-web-developer)

    I have this resolved, at least for my setup. I was adding a trailing slash to all urls. However, the itsec setting is “Login URL:http://www.domain.com/wplogin“. Note there is no trailing slash. Now I don’t redirect urls to keep trailing slash, and I can log in at wplogin. Not too cool, but at least this works.

    4th_dimention

    (@4th_dimention)

    For me it’s not working even without the slash. I realize I am probably not providing enough information to solve the issue, but I don’t even know what information would pertain to the problem.

    iThemes Support

    (@ithemes-support)

    Hey All,

    Thanks for reporting this. I’ve spoken with Chris and he’s going to add the ability to use a trailing slash.

    @4th_dimention – Could you please file a bug report and provide as many details as you can including your login URL?

    iThemes Security Bug Report

    Thanks,

    Gerroald

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Login Hide Backend’ is closed to new replies.