Support » Plugin: Plainview Protect Passwords » login errors under 4.8

  • Resolved tvalleau

    (@tvalleau)


    WP-login fails with these errors, despite a delete and reinstall of PPP:

    Warning: Declaration of plainview\protect_passwords\traits\protection::get_user_capabilities($user_id) should be compatible with plainview\sdk_propas\wordpress\base::get_user_capabilities() in /home/edwinuser/azreealine.org/wp-content/plugins/plainview-protect-passwords/src/Protect_Passwords.php on line 9

    Warning: Cannot modify header information – headers already sent by (output started at /home/edwinuser/azreealine.org/wp-content/plugins/plainview-protect-passwords/src/Protect_Passwords.php:9) in /home/edwinuser/azreealine.org/wp-login.php on line 396

    Warning: Cannot modify header information – headers already sent by (output started at /home/edwinuser/azreealine.org/wp-content/plugins/plainview-protect-passwords/src/Protect_Passwords.php:9) in /home/edwinuser/azreealine.org/wp-login.php on line 409

    —-

    I have disabled the plugin and have access once again.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author edward_plainview

    (@edward_plainview)

    What version of PHP are you using? My v 7 doesn’t give a warning.

    At any rate, if you disable WP_DEBUG you won’t get the above warning and you’ll be able to log in again.

    I’ll release a fix soon anyways.

    Thanks for getting back to me! 🙂

    My php is 7.0.13.

    Unfortunately, WP_DEBUG is already set to “false”

    • This reply was modified 2 years, 1 month ago by  tvalleau.
    JJNW

    (@jjnw)

    Hello, there. I have same problem. Will use plugin when you can get it fixed… I chased down the error for several hours. No luck. Using php 5.5.12 WP 4.7.5.

    Thanks for trying, hope you are able to track this issue and giv’er a fix 🙂

    Yes, shows only with WP_DEBUG on… I always keep these on while developing:

    define( 'WP_DEBUG_LOG', true );
    error_reporting(E_ALL); 
    ini_set('display_errors', 1);
    define('WP_DEBUG', true); 

    I have 64 plugins running clean now.. except your plugin 🙁

    gozalbes

    (@gozalbes)

    Hi:

    I have the same error, running PHP 7.1.7 and WordPress 4.8

    mod_fcgid: stderr: PHP Warning: Declaration of plainview\\protect_passwords\\traits\\protection::get_user_capabilities($user_id) should be compatible with plainview\\sdk_propas\\wordpress\\base::get_user_capabilities() in *******/wp-content/plugins/plainview-protect-passwords/src/Protect_Passwords.php on line 9

    The error is shown in Apache error.log

    I am getting the same error WP 4.8

    +1
    thank you

    Plugin Author edward_plainview

    (@edward_plainview)

    Uploading v1.2 now. Does this version work any better?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘login errors under 4.8’ is closed to new replies.