Login doesn't work (3 posts)

  1. SuperSkier
    Posted 3 years ago #

    1. Via Control Panel and Fantastico, I set up new WP 3.1 installation in a subdirectory (created by installation).
    2. Attempted to “visit site” from Fantastico at end of installation process and IE was unable to connect.
    3. Attempted to go to site via domain/subdirectory (patentlawportal.com/patent-blog/). Same problem. Tried Firefox and got page not directing properly.
    4. Added /wp-login via IE and got the normal WP login page (login box in the middle of the page with WP logo over it. Entering Username and PW results in resetting with removal of both entries. Note: Firefox requires the .php to be added otherwise a 404 error occurs. (Using index.php also doesn’t work.)
    5. Via phpMyAdmin verified that database had been created and that all looks normal in tables for wp_users and wp_options. Also verified that the wp-config.php file correctly identifies the db name (wp-config.php was set up by Fantastico installation). For the username, it lists the db name, not the user name that I put in – I’ve tried the db name as the username to login, but that didn’t help. For PW it has a gibberish PW instead of what I put in, but that doesn’t work either. Host is localhost, which should be correct.
    6. Replacing the username and PW with the login name and PW that I selected at least does something (the page tab shows that it is connected to the correct place instead of just to patentlawportal.com (URL stays the same at the top), but results in a blank page (including source). Trying to get the login page back fails, even after refreshing after a cache clear. Restoring the Fantastico setup and clearing cache and cookies gets it back.
    7. Note: There is a prior MySQL database with an old WP installation in it (same domain/different subdirectory). Could this somehow be interfering? (I could delete it as I am starting over completely – only left it there in the hope that it might be of use – it also cannot be accessed which is what prompted the new installation; however, DROP DATABASE is disabled and can only be done through the installation from Fantastico page, but Fantastico page doesn’t find the other db, so I’m not sure how I can remove this other db.)
    8. I’ve most of what I did above was after looking at the WP support forum, but so far haven’t found something that works for my problem.
    9. Host has always been the same LunarPages.

    Thanks in advance for your help.

  2. brough
    Posted 3 years ago #

    I have almost exactly the same problem. Standard Fantastic installation - same as I've done many times before and once quite recently with WP - and it rejects login. Had it mail me a new one - rejects that too. Have reinstalled system twice, and removed all other databases from domain.
    Will post here when I find solution.

  3. brough
    Posted 3 years ago #

    Problem turned out to be .htaccess in the root directory.
    Removed the following lines:
    # forces www
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^mydomain.net.au$
    RewriteRule ^(.*)$ http://www.mydomain.net.au/$1 [R=301,L]

Topic Closed

This topic has been closed to new replies.

About this Topic