WordPress.org

Forums

WP Login Box
[resolved] Login brings me to the WP Login form (10 posts)

  1. xiot
    Member
    Posted 1 year ago #

    Hi,

    I was wondering why the plugin does root me to the WP Login form every time I try to log in.

    I enter name and password and hit Login. It redirects me to the WP Login Page without any Data entered and i have to reenter it again.

    Thanks in advance

    http://wordpress.org/extend/plugins/wp-login-box/

  2. Ziv
    Member
    Plugin Author

    Posted 1 year ago #

    make sure the option, "Disable WP-Login redirects?" is turned off.

  3. xiot
    Member
    Posted 1 year ago #

    Tried it turned on and off.

    Same reaction in both ways

  4. xiot
    Member
    Posted 1 year ago #

    I have to admit i have a local version, where it is working properly. But i have no clue why it shouldnt do it in the online version.

    http://gamerslottery.com/

  5. Ziv
    Member
    Plugin Author

    Posted 1 year ago #

    I just visited your site and hit login.
    It brought me to wp-login.php. I am using Chrome.
    This is weird, I will check this out and your other problem.

  6. xiot
    Member
    Posted 1 year ago #

    Ok,
    I tried to reconstruct the environment I had offline.

    With WP Hide Dashboard and Profile Builder. I installed them both and got the same result.

    As you said I get it even when I only hit Login Button.

    I changed the blog URL from the install directory. With the index.php and .htaccess . Can it come from there?

    Next is that I added the WP Login Box to the header. But I also tested the plugin and shortcode (both brought up the same problem)

    I'd have another idea. Maybe some Permission issues with the configs, although your plugin didn't give me an error when i changed something. I have no FULL Write Permission (Changed nothing and had to write my own .htaccess file and upload it per ftp)

    So now that's all I got with my "skills" :D

    Thanks anyway, hope my ideas and circumstances could help bringing you to the solution.

    Greetz from Germany, Lars

    EDIT: I got WordPress 3.5.1 offline and 3.5.2 online
    2nd EDIT: Just updated the offline version to 3.5.2 and your plugin is still working

  7. xiot
    Member
    Posted 1 year ago #

    Ok, i worked a bit on this issue and found out that the problem doesn't appear when the Site URL is the same as my WordPress URL.

    my wordpress installation is gamerslottery.com/wordpress
    and i configured the site to gamerslottery.com

    When i add the /wordpress to site URL it's working just fine.

    So, there is the prob. Some advice from you? Maybe a small code snippet for your plugin or do I have to install WP to ROOT now?

    Thanks for your help, hope I don't bother you too much.

    Lars

  8. Ziv
    Member
    Plugin Author

    Posted 1 year ago #

    I took a look at the HTML markup of the plugin in your site and noticed the value of the "action" attribute is:
    http://gamerslottery.com/wp-login.php
    and not:
    http://gamerslottery.com/wordpress/wp-login.php

    I edited the value and entered http://gamerslottery.com/wordpress/wp-login.php and the plugin worked.

    In my plugin, I used a function that returns the home url and not the site url, which is the reason the wrong value is in the action attribute. I think this function is the correct one.

  9. xiot
    Member
    Posted 1 year ago #

    Great, it's working now!

    Changed the get function from home url to site Url in Out.php and the problem is solved!

    Thanks for this great support!

    5 Stars for this plugin!

  10. Ziv
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Login Box
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.