Support » Multisite » [Resolved] Login attempt to network admin kicks to login screen

[Resolved] Login attempt to network admin kicks to login screen

Viewing 11 replies - 1 through 11 (of 11 total)
  • Flush all your cookies and cache for the site however….

    Notice how one of the ‘mysite.com’s has www in front and one does not? It LOOKS like you set your site up with a combination of www and non-www in the domain name.

    Yes, I am all-but-certain that is the heart of the problem. I was originally going to go with the subdomain structure, and removed the www from some of the settings in preparation for that…then decided not to do it afterall (see what you get for being wishy-washy) 🙂

    I think that, once you enable the network, the blog URL fields disappear from the settings panel. Kind of confusing, to see them, and then not see them (I’m scratching my head saying “am I going crazy?”)

    Ultimately, I logged into the database and fixed the setting, removing the www from the blog address. That allowed me to log in as network admin.

    But my Firefox refuses to accept that answer, as it keeps trying to “over-guess” my inputs, replacing them with the “www” no matter what I do (clear cache, drop cookies, etc). When I use Safari, it’s all good.

    Anyway…problem solved.

    Now that I have had the chance to use it a wee-little-bit, the Multisite functionality seems to have some inefficiencies for the writer, IMHO. I don’t have the PHP chops to do it differently, but I can see it in my head as making posting to multiple blogs much more convenient.

    For instance, if you are the super-admin, and have one or more blogs, why doesn’t the post panel just give you a “master control” where you could check a box (as you would for category) for a given blog, and it posts the content to the checked blog. As well, if you wanted to post the same story to multiple blogs in your network, tick the checkboxes for the blogs you want that story posted to. Is this already possible, and my install is gummed up, or is there some stylistic reason why it’s not done this way? What am I missing here, because it seems so “slam-dunk obvious” that the smart folks who developed this functionality surely would have thought about this.

    Nonetheless, very grateful Multisite exists.

    Thanks for your reply, Ipstenu, and your eagle eyes on the URL string!



    or is there some stylistic reason why it’s not done this way?

    because it wasn’t made for one user to have multiple blogs to post from behind one interface. 🙂 It was made to create a blog hosting service like wordpress.com. 😉

    Now, see, that makes a whole bunch a sense.

    Does anyone know if there is a plugin or third-party service out there that does what I’m talking about (central “command center” posting on multiple blogs from one interface)?

    I use HootSuite to do this for social networks. And, as I am typing this, I just noticed they support WordPress…but only wordpress.com

    Thanks, Andrea, for clarifying the mission of this functionality. I am late to the party, obviously.



    Broadcast a post/page to other blogs. Whitelist, blacklist, groups and automatic category+tag posting/creation available.
    * http://wordpress.org/extend/plugins/threewp-broadcast/

    Allows you to duplicate posts and pages to multiple sub-blogs at once.
    * http://wordpress.org/extend/plugins/multipost-mu/

    or a desktop client like… scribefire? man I wish I could remember what it was called.

    I’m having this same issue in multisite – it seems that when I go to the “Updates” link in the top hovering menu bar, it trims off the “www.” from our domain name, while every other option keeps it in there. If I go directly to “domain.com/wp-login.php”, and log in there, it refreshes the login screen and seems to go nowhere. However, if I log in at “www.domain.com/wp-login.php”, it gets me into the Dashboard, and then the “Updates” link works fine.

    Basically, if the Network Admin links didn’t cut the www. prefix off, this problem likely wouldn’t exist. Any idea why it does this? All of the non-Network Admin links leave the www. on, and they work fine.

    Same as above – somewhere in the db you have a url without the www on it.

    No, that’s not it – I’ve tried changing it in the database to domain.com and http://www.domain.com , and it has no effect. I think it’s because the network admin link is using PHP’s value for $_SERVER[‘SITE_HOST’] or something similar, even though none of the other links at the top of the bar use this constant.

    I’d be glad to change it myself, but I don’t know what file(s) those links are found in. Any idea?

    You could put in an .htaccess redirect to force the use of www.

    That sounds interesting – I’ve done a little .htaccess hacking, but I have to admit I don’t understand the syntax fully. I googled and found this example:

    RewriteCond %{HTTP_HOST} !^www\.domain\.com [NC]
    RewriteRule ^(.*)$ http://www.domain.com/$1 [R=301,L]

    Would this force things like http://domain.com/superblog to become http://www.domain.com/superblog?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Login attempt to network admin kicks to login screen’ is closed to new replies.