Support » Plugin: Apocalypse Meow » Login activity empty, error message “The server garbled the last response”

  • Resolved nicatams

    (@nicatams)


    Hi,

    Thank you very much for your plugin.

    I installed, this step went well.

    I see “Login activity” in the menu, I click, I expect a list, but no list is shown up, instead on top, there is an error message:

    The server garbled the last response 🙁

    Sweet, the smiley, but what’s going on? 😉

    Browser platform:
    Windows 7 SP1, incl. all updates
    Firefox 57.0.2 x64

    Server platform:
    PHP 7.0.25
    WordPress 4.9.1
    Apocalypse Meow: 21.3.1
    Table wp_meow2_log contains 2 records, they seem to be populated well and correctly

    While finishing this message, to provide as much information as possible, and of curiosity, I try to view the log using another browser, Internet Explorer 11 bundled with Win7, this way I can see the log as expected, without the “garbled” error.

    Any idea how we / I can workaround the “garbled” error in Firefox?
    Could it be related to a Firefox plugin?
    Where can I look for logging or debugging about this, any idea?

    Thank you!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Blobfolio

    (@blobfolio)

    Thank you for all the details!

    I took a look at some Activity pages in Firefox 57, 57.0.1, and 57.0.2 in a few Windows/Linux combinations but wasn’t able to reproduce that.

    Which is not to say you’re crazy. Haha. The answer is just going to be a bit more obscure. 🙂

    There are two quick things to check, if you don’t mind:

    • Try logging into your site using Firefox’s “Private Window” (SHIFT + CTRL + P I believe). Make your way to the Activity page. Does it work here?
      If so, it might be either a cache issue or an add-on that is interfering with the page. (Back in the regular session, you could try temporarily disabling browser extensions to see if that makes a difference, or clear the browsing data for your site.)
    • Another thing you could try: go to the Activity page (Private or not, doesn’t matter) and hit SHIFT + CTRL + I to open Firefox’s “Inspect Element” tool. Click its Network tab, then reload the page. As the page reloads you should see a bunch of different requests fill up that Network tab. Click “XHR” to filter that list to AJAX requests, and click (probably the first) entry in that list. That should pull up the request details in its own little box, and if you click that box’s “Response” tab, you should see a nice JSON tree with entries like ‘page’, ‘pages’, ‘items’… If you see something else, like perhaps a WP_DEBUG notice at the top, that’s the “garble”.

    Please let me know if either of those steps provide any insights, or if Firefox still doesn’t like the page. 🙂

    And thank you again for taking the time to help debug!

    Plugin Author Blobfolio

    (@blobfolio)

    Hi @nicatams,

    I forgot to mention earlier, if none of my suggestions revealed the nature of the issue, I do have a pre-release of the plugin that switches between the development and production versions of Vue.js (a framework used to render complex pages like the Activity) based on the WP_DEBUG constant. That might provide a more useful console error for you.

    Hello!

    Thank you for your answer and ideas.

    Tonight, I logged on, and surprisingly, thie first attempt to look to the Activity, shows a list. In my happyness, I clicked the option Stats, there was the “garbled” back. I return to Activity, again “garbled”.
    That was in Firefox “normal mode”.
    In Private mode, I only see the “garbled”.

    I followed your instructions for the Inspector, I do see the response containing lines and records from the database, containing the expected information that should be shown in the Activity list.
    I see a tree structure for the JSON title:

    data: {…}
    page: 0
    pages: 2
    total: 147
    items: […]
    0: {…}

    49: {…}
    bans: […]
    0: {…}

    3: {…}
    errors: []
    msg:
    status: 200

    Below this, a block with title “Response payload”.
    It roughly contains the same information, but in one line instead of each item on a new line.

    At first sight, there is no WP_DEBUG in these results.

    So, I think, the data is pulled out of the database well, and somehow, it’s not converted into a nice lay-out.

    The number 49 is unclear for me, the Meow2 Log table contains 151 rows.

    During this test, I saw I was using a Dutch language setup of Firefox, I replaced it by the English/UK language edition, same 57.0.2 x64, same issue.
    Meanwhile, also the addblocker disabled, still this issue.

    I did the same on my Mac, additional information is shown in this window:
    First, it’s with Firefox 52.0.2 for Mac:
    Same steps as above, below the “response payload”, a small window with red background says:

    TypeError: t.bind is not a function
    Stack trace:
    e@https://[url]/wp-content/plugins/apocalypse-meow/js/vue.min.js?ver=20171204:1:86079
    X.then@https://[url]/wp-content/plugins/apocalypse-meow/js/vue.min.js?ver=20171204:1:92361
    vue.min.js:1:89617
    B/</< https://[url]/wp-content/plugins/apocalypse-meow/js/vue.min.js:1:89617
    B/< https://[url]/wp-content/plugins/apocalypse-meow/js/vue.min.js:1:89576

    On the Windows computer, I can’t find this error or any screen telling something about an error.
    Is this piece telling you something?

    Plugin Author Blobfolio

    (@blobfolio)

    Woo!

    I did have a fix for the Stats page queued up, so I went ahead and pushed a new release of the plugin (21.3.2) just now. I think that should fix it for you. (The problem there is that relatively new installs might not have enough data for some of the charts.)

    WP_DEBUG is a constant you can define as TRUE or FALSE in your wp-config.php file. It can be helpful to turn that on when developing a site, but should generally be disabled once the site is live.

    The newest release of Apocalypse Meow will enqueue the development version of Vue.JS (which provides more helpful Javascript details in the console log) if WP_DEBUG is on, otherwise it loads the smaller production version.

    Thank you again for taking the time to do all this debugging! Please let me know if you encounter any other issues!

    Plugin Author Blobfolio

    (@blobfolio)

    Oh I apologize, I think I misread your reply: are you saying that the Activity page is back to displaying the “garbled” response errors in Firefox, though only sometimes?

    Does the most recent release (once your WP acknowledges there is an upgrade) fix the issue with the Stats page?

    Other than an Ad blocker, do you have any other Firefox extensions installed? Or any experimental flags enabled?

    The only other outside factor I can think of would be an overly-zealous antivirus application. As an outside test, if you temporarily disable Norton/McAffee/whatever (assuming your Windows machine is running one), does that change anything?

    Plugin Author Blobfolio

    (@blobfolio)

    Sorry, @nicatams, one more follow-up question: are you able to save configuration changes on the main Apocalypse Meow settings page in Firefox?

    All three pages (Activity, Stats, and Settings) use similar mechanisms to send and receive data from the server. If all three are acting weird, that probably points to a more foundational issue.

    Hi,
    Thanks for the work and follow-up!

    WP is running the latest edition, 4.9.1. No updates announced. So I can’t update this one 😉
    Yesterday night, I started set up a test environment. Dump of DB and FTP of files worked well, but a white page. So no test environment available yet. I continue tonight.

    I confirm: Sometimes, the Login Activity and Login Statistics show data, most of the time they show the “garbled” and no stats.

    This morning, I found out the Login Activity is always shown the first time after opening Firefox and logon to the back-end of my website.
    I did a short test: right-click the menu option “Login Activity” and “Open in a new tab” and yes, this way, every time, I see the stats as expected.
    Same for Login Stats: Via “Open in new tab”, it goes well.

    With your new version, the “sometimes” is less, but not gone, I’m sorry.
    But, the trick of this morning continues: Via “Open in new tab”, the pages show up correctly, no errors.

    Saving settings was never an issue or didn’t result into errors.

    Wild guess: Memory issue with FF? If a new fresh tab, without ‘history’ shows up the page well, and after this first try, errors start to show up… ?

    Plugin Author Blobfolio

    (@blobfolio)

    Thanks for the followup, @nicatams!

    That is sounding like a possible memory issue. Here’s a quick test for you:

    Press SHIFT + CTRL + I to open the Inspection panel again. Click over to its “Network” tab, and check the box to “Disable Cache”. Leaving that pane open, if you go to Activity multiple times, does it behave any differently?

    In the meantime I’ll keep trying to reproduce the behaviors on my end and see what I can do to fix them.

    Hi,

    No difference.

    I tried to look into the other tabs, to discover anything.
    Nothing strange or nothing that could indicate something.
    I looked to the tab “Memory”. No pattern.
    For Network and only XHR selected, I looked to Headers, cookies, params, response, timings, stack trace, security. No pattern. No differences between a good and a bad response.

    I continue to set up my Test server, with a copy of the Live website and a second Test website, filled with some random pages.
    And see how the Meow will ‘sound’ 😉

    I keep posted.

    Plugin Author Blobfolio

    (@blobfolio)

    Hi @nicatams,

    Thank you for all of your efforts!

    I still haven’t been able to reproduce the issue myself, but have tried out a few JS changes that I’m hoping will help.

    Do you mind trying out a pre-release build?https://storage.blobfolio.com/apocalypse-meow-21.3.3-pre.zip
    MD5: 6dfd6235ccc8545595e27ba8723bf3b4

    The contents of the Zip can be uploaded via FTP directly over the existing files, but to be safe, you should temporarily disable the plugin first. (Then once everything is uploaded, you can reactivate it.)

    Thanks again!

    Plugin Author Blobfolio

    (@blobfolio)

    Hi @nicatams,

    The latest version (21.4.0) includes the aforementioned JS changes, so you can disregard my last post asking about trying the pre-release build.

    But I would still be interested in knowing whether or not this latest release fixes the issues you’ve been seeing in Firefox. 🙂

    Happy holidays!

    Hi Blobfolio,

    Happy holidays and best wishes for the new year!

    I just installed your new version. All seems to show well, from the very first click, during browsing (click an IP for details, click again on ‘activity’), the Stats and graph, back to ‘activity’.
    It shows well, first shortly the message with green line in front, and then the data as expected.
    Nice job! Thank you for repairing/bugfixing!

    For my interest: Which part of code did you have to adapt? Does it refer to an issue specific to Firefox?

    Plugin Author Blobfolio

    (@blobfolio)

    Happy new year, @nicatams!

    The change that I think fixed things for you comes down to the timing of the search auto-submission.

    The search form used to be submitted as soon as Vue.js reported it was ready to go, but now it waits until the browser triggers the window.load event.

    I was never able to reproduce this on my test sites or virtual machines, but I suspect there was either something rearranging (“optimizing”?) the requests or HTML generated by WP specific to your site setup (a theme or plugin maybe), or Firefox’s new Quantum Engine was sometimes a bit too smart or fast, running Vue earlier or later than expected.

    At any rate, window.load only fires once everything from the page (scripts, styles, images, etc.) is ready to go, so I guess that is taking care of any accidental rearranging. 🙂

    Thank you again for all the feedback! I really appreciate it.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Login activity empty, error message “The server garbled the last response”’ is closed to new replies.