Support » Plugin: Asgaros Forum » Login

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Asgaros

    (@asgaros)

    Do you have a link for me so I can check this?

    Yes, it is http://p3georgia.org/forum-2/.

    Thanks.

    Just following up to see if you have had a chance to see what is wrong with the login. Thanks.

    Plugin Author Asgaros

    (@asgaros)

    It is linking to:
    http://p3georgia.org/wp-login.php?redirect_to=http%3A%2F%2Fp3georgia.org%2Fforum-2%2F

    There is a redirect_to parameter at the end, so the login-page is always redirecting back to the forums page. I am not sure why, maybe something is overriding this.

    Maybe you can try this. In the following files:
    asgaros-forum/includes/views/forum.php
    asgaros-forum/includes/views/thread.php

    Somewhere at the beginning there is a line like this:
    echo '<div class="info">'.__('You need to login in order to create posts and topics.', 'asgaros-forum').'&nbsp;<a href="'.wp_login_url(get_permalink()).'">&raquo; '.__('Login', 'asgaros-forum').'</a></div>';

    You can try to change it to this:
    echo '<div class="info">'.__('You need to login in order to create posts and topics.', 'asgaros-forum').'&nbsp;<a href="'.wp_login_url().'">&raquo; '.__('Login', 'asgaros-forum').'</a></div>';

    Is it working after this modification?

    Unfortunately, that does not seem to have worked. Any other thoughts?

    Plugin Author Asgaros

    (@asgaros)

    Please check your other plugins for this. Maybe you are using some custom-login plugins or something like that?

    There is added a wrong redirect_to parameter which is not set by the forum plugin so something other has to be responsible for this.

    Thanks – cleaned up my plugins and it now appears to be working.

    I’m having the same problem. It says the person must login, but clicking on log in does nothing but takes them to the homepage of my blog. I don’t know what alisonpaul meant by she cleaned up her plug in. Can you please assist?

    I had a WP Registration plugin installed that was interfering with the forum app. I deactivated it and the forum login then worked.

    I just deactivated the following plugins:
    Advanced custom fields
    Quiz player
    Eclipse crosswords
    Wordpress Importer
    WP product review

    and this still won’t work. I need to keep my other plugins, so I guess I have to choose another forum plugin that is more compatible. I even changed the code, but just like it didn’t fix the problem for you, it doesn’t fix it for me. Too bad. I’m guess I’m back on the prowl.

    Thanks for your help alisonpaul ๐Ÿ™‚

    Plugin Author Asgaros

    (@asgaros)

    As I wrote in your review:

    You should try to temporary disable the plugins which are not listed in your post before to find out which one is responsible for it. After it you should contact the plugin-author so it can be fixed.

    This is not a bug/problem inside the Asgaros Forum plugin because some other plugin seems to mess around with a core-WordPress-function.

    I had the same problem and it was the cache plugin I was using. Cleared the cache and now it works. Thank you very much for a really nice looking forum plugin. I am using WP version 4.7.4

    Barry

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Login’ is closed to new replies.