Support » Plugin: BBQ Firewall » Logging not working?

  • Resolved swissspaceboy

    (@swissspaceboy)


    Hi Jeff,

    I activated the logging mechanism via the custom plugin. I got this today in my error log:

    [27-Jul-2021 13:16:39 UTC] BBQ: ...
    [27-Jul-2021 13:16:39 UTC] BBQ: ...
    [27-Jul-2021 13:16:39 UTC] BBQ: ...
    [27-Jul-2021 13:16:40 UTC] BBQ: ...
    [27-Jul-2021 13:16:40 UTC] BBQ: ...
    [27-Jul-2021 13:16:40 UTC] BBQ: ...
    [27-Jul-2021 13:16:40 UTC] BBQ: ...
    [27-Jul-2021 13:16:41 UTC] BBQ: ...
    [27-Jul-2021 13:16:41 UTC] BBQ: ...
    [27-Jul-2021 13:16:42 UTC] BBQ: ...
    [27-Jul-2021 13:16:42 UTC] BBQ: ...
    [27-Jul-2021 13:16:45 UTC] BBQ: ...
    [27-Jul-2021 13:16:45 UTC] BBQ: ...
    [27-Jul-2021 13:16:47 UTC] BBQ: ...
    [27-Jul-2021 13:16:47 UTC] BBQ: ...
    [27-Jul-2021 13:16:48 UTC] BBQ: ...
    [27-Jul-2021 13:16:48 UTC] BBQ: ...
    [27-Jul-2021 13:16:49 UTC] BBQ: ...
    [27-Jul-2021 13:16:49 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:50 UTC] BBQ: ...
    [27-Jul-2021 13:16:51 UTC] BBQ: ...

    Any idea what this might be or mean?

    Thanks,

    Didier.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Looks like misconfiguration. Have you tried to test any patterns like eval( to see if they are recorded?

    Thread Starter swissspaceboy

    (@swissspaceboy)

    Yes, eval is well logged

    [27-Jul-2021 20:34:40 UTC] BBQ: eval(

    Plugin Author Jeff Starr

    (@specialk)

    Then something must have hit your site with a bunch of requests that included three dots, as shown in the log. Try another test, this time include three dots: ...

    I.e., three dot pattern is blocked by BBQ.

    • This reply was modified 1 month, 3 weeks ago by Jeff Starr.
    Thread Starter swissspaceboy

    (@swissspaceboy)

    aha..many entries in the log from this naughty one:

    31.13.103.118 - - [27/Jul/2021:15:16:38 +0200] "GET /.../propagande.../ HTTP/1.1" 403 0 "-" "facebookexternalhit/1.1 (+http://www.facebook.com/externalhit_uatext.php)"
    

    This is not a valid URL /…/ I guess?

    Didier.

    Plugin Author Jeff Starr

    (@specialk)

    Yeah that’s not a legit request, so it is blocked.

    Plugin Author Jeff Starr

    (@specialk)

    Do you still need help with this, Didier? If not, I would like to mark as resolved. Thank you.

    Thread Starter swissspaceboy

    (@swissspaceboy)

    Hello,

    Yes, error logging is working fine. That “…” got me confused.

    Closed and thanks for the support !

    Didier.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.