WordPress.org

Support

Support » How-To and Troubleshooting » logging into the administration area

logging into the administration area

Viewing 8 replies - 1 through 8 (of 8 total)
  • Let’s say the domain name of your blog is http://www.widgets.com. You should be able to find the WordPress login at http://www.widgets.com/wp-admin where you should see a “Lost your password?” link that will help you recover your password.

    Thanks. I gave it one of two emails I thought it would be and it pulls up one of the mock users I entered for my blog. this user should not have admin privilidges. ? in wp-admin is there a php file this info is in? the mysql database shows my mock user with my actual email address, but this should not be the administrator. or is the administrator listed in the database users table too, and I deleted it a while back, not knowing its the administrator?

    If you are comfortable with code you might try to manually recreate an admin user in the database. However, I would advise you avoid manually doing anything with the database if you can avoid it since it is terribly easy to mess up your site if you don’t know what you are doing.

    http://wordpress.org/support/topic/re-create-admin-account-via-phpmyadmin?replies=5

    Personally, I would just try to install all over again since it sounds like you never really did anything with it.

    thanks for the info. I may give it a try as, the way it is I don’t want to fuss with it anymore and would delete it anyway.

    I tried what all the links suggested and nothing. I tried this bit of code and even deleted the wp_usermeta table after the insert command didn’t work and tried to create table firstly.

    INSERT INTO ‘wp_usermeta'(‘umeta_id’,’user_id’,’meta_key’,’meta_value’) VALUES
    (1, 1, ‘nickname’, ‘admin’),
    (2, 1, ‘rich_editing’, ‘true’),
    (3, 1, ‘admin_color’, ‘fresh’),
    (4, 1, ‘wp_capabilities’, ‘a:1:{s:13:”administrator”;b:1;}’),
    (5, 1, ‘wp_user_level’, ’10’);
    then tried
    CREATE TABLE wp_usermeta(‘umeta_id’,’user_id’,’meta_key’,’meta_value’) VALUES
    (1, 1, ‘nickname’, ‘admin’),
    (2, 1, ‘rich_editing’, ‘true’),
    (3, 1, ‘admin_color’, ‘fresh’),
    (4, 1, ‘wp_capabilities’, ‘a:1:{s:13:”administrator”;b:1;}’),
    (5, 1, ‘wp_user_level’, ’10’);
    and get the error
    SQL query:

    CREATE TABLE wp_usermeta(
    ‘umeta_id’,
    ‘user_id’,
    ‘meta_key’,
    ‘meta_value’
    ) VALUES ( 1, 1, ‘nickname’, ‘admin’ ) , ( 2, 1, ‘rich_editing’, ‘true’ ) , ( 3, 1, ‘admin_color’, ‘fresh’ ) , ( 4, 1, ‘wp_capabilities’, ‘a:1:{s:13:”administrator”;b:1;}’ ) , ( 5, 1, ‘wp_user_level’, ’10’ );

    MySQL said: Documentation
    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ”umeta_id’,’user_id’,’meta_key’,’meta_value’) VALUES
    (1, 1, ‘nickname’, ‘admin” at line 1

    well I found a link that went thru the steps of altering the wp_ users, and wp_usermeta tables from the phpmyadmin screen. so now I get the error when logging into WP: “You do not have sufficient permissions to access this page” now, how to change this?

    Why don’t you just drop all the tables from the database in phpmyadmin and navigate to your main URL and you will be prompted to reinstall WordPress?

    dear geekygordon,
    I did drop the tables and when I try to log in with my new admin login & password I get:
    Fatal error: Call to undefined method WP_Styles::reset() in /home/a5276870/public_html/wordpress/wp-includes/script-loader.php on line 713 ?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘logging into the administration area’ is closed to new replies.
Skip to toolbar