Support » Plugin: W3 Total Cache » Logged users on cached pages are not logged

  • If users have some pages cached. After the successful login when users visit that pages again it is not logged on that pages. On pages that are not cached there is not this problem.

    “Don’t cache pages for logged in users” is ticked.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi @amedic,

    How are you logging user visits on pages? If through a plugin, what is it?

    Plugin Contributor gidomanders

    (@gidomanders)

    @huenisys He means the users do not appear logged in on the pages they visit, so they see a “login” button instead of a “my account” button, something like that.

    @amedic Could you share your wp-content/w3tc-config/master.php file and .htaccess file so I can try to replicate your issue?

    bgdstr

    (@bogdanstratulat)

    Hello @amedic,

    I tend to believe that the issue is related with a setting within the w3 total cache plugin. Please follow the steps from below:

    From the left menu select Page Cache > General . and from there please make sure that the plugin is set up to :
    Don’t cache pages for logged in users
    Don’t cache pages for following user roles: Administrator, Editor, Author, Contributor and Subscriber.

    I hope this helps!

    bgdstr

    (@bogdanstratulat)

    Can we get an update regarding this issue? Has this been sorted out?
    If so, please feel free to close and mark this topic as resolved.

    Thank you for using W3 Total Cache

    Kind regards!
    Bogdan S.

    I have the same situtaion on my Woocommerce Shop.

    Description of problem:

    I am guest user, and browsing throw web shop. Navigate to some page or item, and click top right login section, and logg in to store. On that page I see that I am logged in, everythin is ok. But if I click to Home Page, or some other cached page where I was before my login process, it will not be visible in top right corner that I am logged in.
    I am desperate, and that problem is active more then a year.

    No cache for logged users is enabled on my WordPress admin section.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @miloszivkov,

    you need to change the browsePerformance>Browser Cache cache control to an option with validation (preferably cache with max-age and validation)

    Hi @vmarko ,

    I did it like you said. I have changed on 3 places to Max age and Validation.

    Peformance > Browser Cache > (CSS and Js, HTMl and XML, Media and other files)

    On mentioned 3 places now I have enabled:
    “keširati sa max-age i validacijom (“max-age=EXPIRES_SECONDS, public, must-revalidate, proxy-revalidate”)”

    Situtation is same.
    Descritpion of problem:

    I am browsing as guest user throw Woocommerce Store (in background static cached pages are generated)
    From some random page I go to login section, and log in to store. System redirects me to My Account page, everything is ok.
    While I am logged in, click on home page, and I get cached page, where “I am not logged in at top right section”.
    Click on refresh button on my browser, and my username appear. If I not click on refresh, there is no my username at top right.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @miloszivkov,

    Please disable the expires header In Performance>Browser Cache and you also need to clear browser cache, otherwise, it will still be there.
    There is no way to clean it from outside in this case

    Mikey

    (@mikeyhash)

    I have the same issue as the guys above: The user logs-in, but when going on the front page, he receives a cached page as non-logged-in.

    How to solve this best (the goal is to not lose the speed of page loadings)?

    1) Enabling the “Don’t cache front page” checkbox in Page Cache?
    2) Disabling expires header in Browser Cache?
    3) What else can be done?

    milos.zivkov

    (@miloszivkov)

    After almost 10 days I didn’t solve the problem. Changed 2 hosting machines, changed everything I could in Plugin Settings, but this doesn’t work.

    Logged user will always load cached pages. Whatever you select in configuration settings situation is same.

    However this plugin is awesome, performance of website and speed is perfect. I want to buy pro licence also, but problem with logged user cache is present, also as Page Fragment Caching didn’t work for me.

    Regards

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @miloszivkov,

    Please follow the steps on our FAQ page and reply back with the result.

    csandreas1

    (@csandreas1)

    Well i have the same problem. On the top of the header there is a login widget that pops up the login form. It is developed by the theme developers.

    Well that thing has to be dynamic and not static.. Each time you click the button it should request data from the server and not just show the cached js /html file

    Plugin Contributor gidomanders

    (@gidomanders)

    @csandreas1 As mentioned before, you have to go to Performance > Browser Cache and disable the expires header for HTML. Also set Cache Control Policy to cache with validation. If you have disabled page cache for logged in users, that should be all you have to do.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Logged users on cached pages are not logged’ is closed to new replies.