Support » Plugin: Math Captcha » logged in users

  • akedv

    (@ak71)


    Hi,

    it’s not possible for logged in users to write comments in the frontend It always says: “ERROR: Please enter captcha value.” but there is no extra field for entering a captcha, just the comment field!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Nothing? Dead plugin?

    Hi!
    I have same problem. It’s because only captcha output is disabled in the settings but the filter is working. You can fix it. Problem in the class-core.php file (lines 56-64) in plugin “/includes” folder. You need to replace these lines with the following:

    // comments
    if ( Math_Captcha()->options['general']['enable_for']['comment_form'] ) {
    	if ( ! is_user_logged_in() ) {
    		dd_action( 'comment_form_after_fields', array( $this, 'add_captcha_form' ) );
    		add_filter( 'preprocess_comment', array( $this, 'add_comment_with_captcha' ) );
    	} else {
    		if ( ! Math_Captcha()->options['general']['hide_for_logged_users'] ) {
    			add_action( 'comment_form_logged_in_after', array( $this, 'add_captcha_form' ) );
    			add_filter( 'preprocess_comment', array( $this, 'add_comment_with_captcha' ) );
    		}
    	}
    }
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘logged in users’ is closed to new replies.