Support » Fixing WordPress » Logged in as . Logout »

  • I’m seeing that message on the comments of any of my posts with any theme I use (including the default).

    If the user is not logged in, the following message will appear:

    “Logged in as . Logout »”

    Since it thinks the user is logged in, there are no options to enter your information and post a comment.

    For reference, here are the comment options I have enabled:

    Before a comment appears:
    * Comment author must fill out name and e-mail
    * Comment author must have a previously approved comment

    Are there any known issues/solutions to this?

    Thanks,

    G.G.

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’m having the same problem. I upgraded from 1.2 to 1.5. Changing themes has no effect. I’ve also noted I can’t disable comments. Should be an interesting spam-fest until this is fixed.

    Help would be greatly appreciated. Additional information can be furnished upon request.

    I too am having this problem. It doesn’t matter what template I use or what the comment settings are — everyone’s an admin when it comes to comments.

    are the few of us the only ones with this problem?? I’ve been able to disable comments, luckily.

    try checking your user list to see if you have a blank user added somehow?

    Holy crap. lawtai, you are a genius! That solved the problem right there! I can’t believe I didn’t even think of that one.

    I am helping a friend set up her WP blog. We imported all of her old MT posts and everything went good, except I was getting the “Logged in as .” message so comments weren’t working. So based on this thread, I had her check and see if there were any blank users to delete. And there was, so she did, and then apparently that user was all of her MT posts, so they all got deleted. So we can import them again, but I am wondering how to deal with this, so that it won’t cause the comments problem? Thanks for any ideas on this.

    Oriecat,

    if you are still having this problem, instead of deleting the user, change its username and password and that should sort the issue for you.

    Tom

    So adding a blank user- so anyone can post… How do I do
    that?

    I tried but it keeps prompting me for a username or email or pw

    How do I do this? all I want is that anyone can post without logging in (I have spam karma2 and wp 1.5.1.2)
    all they would have to do is type their name and maybe email and a image number (to prevent spam).

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Vanbos, it’s easy to allow anyone to comment. Just make sure that “Users must be registered and logged in to comment” is unchecked in Options/General. As for requiring a name and email address, check “Comment author must fill out name and e-mail” in Options/Discussion. And, for the image number, see: http://codex.wordpress.org/Plugins/Spam_Tools#Captcha

    ha ha, got it thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Logged in as . Logout »’ is closed to new replies.