WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate Maintenance Mode
[resolved] Logged in as Admin but can't see site (9 posts)

  1. NFWRo
    Member
    Posted 11 months ago #

    Hi there
    I use your lovely plugin a lot and I've never had a problem before. However, I've just set it up on a site and when I try to look at the site I see the down for maintenance page.

    I saw on this thread http://wordpress.org/support/topic/when-logged-in-cant-see-pages?replies=3 that this can occur when WordPress is in a subfolder, which it is, but then again I usually install to a subfolder. You imply in your response in that thread that this can occur when the subfolder set up is misconfigured. I don't think mine is, but could you tell me what sort of misconfiguration would cause this?

    The site is http://www.chocolicious.co.uk

    Thanks

    https://wordpress.org/plugins/ultimate-maintenance-mode/

  2. John Turner
    Member
    Plugin Author

    Posted 11 months ago #

    Look under you general setting make sure you site and home url match, meaning one contains www and the other one does not.

  3. NFWRo
    Member
    Posted 11 months ago #

    Thanks for the quick reply.

    They match - except the site url does not have the subfolder on it so that the site appears to the public as being just the domain. This is how I normally have it configured.

    So the Site URL is http://www.chocolicious.co.uk and the WordPress URL is http://www.chocolicious.co.uk/subfolder.

    Thanks

  4. John Turner
    Member
    Plugin Author

    Posted 11 months ago #

    Hum, I'm not sure then. This is always the case when I've seen this issue before.

    If you disable the plugin do you see the wordpress admin bar when you view the site? If not then definitely a configuration issue.

  5. NFWRo
    Member
    Posted 11 months ago #

    Ooo - I don't! I wonder why? I'll follow that avenue and see where I get. I'll post back if I find the answer.

    Thanks

  6. John Turner
    Member
    Plugin Author

    Posted 11 months ago #

    Just double check you completed all these steps. https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  7. NFWRo
    Member
    Posted 11 months ago #

    Yes everything there was done.

  8. NFWRo
    Member
    Posted 11 months ago #

    Posted this earlier, but it hasn't appeared - I'm sorry if it lands up being duplicated.

    I followed the thought about the admin bar being missing and found this http://www.scriptygoddess.com/archives/2011/04/29/the-mysteriously-disappearing-wordpress-3-1-admin-bar/ which points out that when you go through the process of changing your settings so that the site appears on the base URL even if you have a subfolder, if you've already looked at your site in browser, your cookies will be set. I had cleared my cache, but not my cookes. Once I'd cleared my cookies too voila - all working. Admin bar appears and I can see the site in Maintenance Mode!

    Thanks for pointing me in the right direction, impressive response times to add to your great plugin. I hope this helps someone else who finds themselves in the same situation.

  9. John Turner
    Member
    Plugin Author

    Posted 11 months ago #

    Awesome! Thanks for posting the solution :)

Reply

You must log in to post.

About this Plugin

About this Topic