Support » Plugin: Shibboleth » “Log in with Shibboleth” not redirecting

  • Resolved maw120

    (@maw120)


    Just installed this plugin (v2.1.1) on v4.9.8, and set up the Login URL/other settings/etc.

    I’m running into an issue where it seems I’m not getting redirected into the shibboleth authentication flow, when I hit the “Log in with Shibboleth” button on the login page, it redirects me to the same login page with ?action=shibboleth but never takes me anywhere. Am I missing some setup?

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Jonathan Champ

    (@jrchamp)

    If you’re seeing the Shibboleth login button, then it should definitely do something. Any other plugins installed? Perhaps would you be willing to share the link to the login page?

    There are some plugins installed but that are inactive. We do have 2 plugins that are “Must-Use” v2.7.1.1 LDAP Authentication Plug-in, and the WordPress MU Domain Mapping. Themes are disabled.

    Currently we’re testing this on an internal server that isn’t accessible from the outside.

    Thanks.

    Plugin Contributor Jonathan Champ

    (@jrchamp)

    I wonder if the LDAP Authentication plugin is taking over… Is it possible to remove that from the Must-Use temporarily?

    Plugin Contributor Jonathan Champ

    (@jrchamp)

    It looks like you might be using this plugin: https://wordpress.org/plugins/wpmuldap/#developers

    Prior to v2.8.4, it used wp_authenticate directly instead of an authenticate hook. Additionally, even with the newest version, that plugin has not be updated in 6 years.

    For now, I’m going to mark this as resolved. If you’re still experiencing issues after addressing the LDAP Authentication plugin, please let us know.

    That was 100% it, thank you Jonathan. I was not aware that plugin was that out-dated, glad we’re moving away from it 🙂

    Thanks again!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘“Log in with Shibboleth” not redirecting’ is closed to new replies.