Support » Fixing WordPress » Log-in but get FATAL ERROR

  • Resolved NAEBAdmin


    I updated my Shashin plug-in, and received an error during the update… Now, the only page get is a Fatal Error:

    Fatal error: Call to undefined method ToppaFunctions::arrayMergeRecursiveForSettings() in /home/content/m/o/r/morse1921/html/wp-content/plugins/shashin/Lib/ShashinSettings.php on line 46

    HELP! I can’t edit the site at all and can’t begin to figure out what the error requires me to do.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator t-p


    disable shashin plugin

    is there a way to do that without loggin in? The issue is that when I log-in, the only page that comes up is the error above.



    Forum Moderator

    FTP into your site (or use whatever file management application your host provides) & delete the wp-content/plugins/shashin folder.

    Actually, you don’t have to delete the folder. All you have to do is rename it and WordPress will automatically deactivate the plugin.

    I got the same error about 15 minutes ago and had to do the same thing. I just FTP’d to the plugins folder, renamed it shashin1, then went back to /wp-admin. Back in the plugins folder, I realized that the Toppa Plugin Libraries it depends on also has an update. I’m guessing we were supposed to update that plugin before shashin. At any rate, after you update the Toppa library plugin, you can re-rename the shashin folder back to its original name, then enable the plugin in WordPress.

    the folder renaming and then updating Toppa worked beautifully! Thanks!! I’ll make note to update Toppa first from here on out…

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Log-in but get FATAL ERROR’ is closed to new replies.