Support » Networking WordPress » log error since last update

  • Hello guys,
    Since last update, I get the following log errors.. do you know if there is something wrong? Thanks

    PHP Warning:  An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration.
    If you continue to have problems, please try the <a href="http://wordpress.org/support/">support forums</a>.
    (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.)
     in /wp-includes/update.php on line 120
    PHP Notice:  Use of undefined constant MULTISITE - assumed 'MULTISITE'
    in /wp-content/plugins/google-xml-sitemaps-with-multisite-support/sitemap-core.php on line 1398
    [error] [client ::1]
    PHP Notice:  Undefined index: HTTP_HOST in /wp-includes/ms-settings.php on line 97
Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you contacted your hosts about this? It looks like a server issue.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    I would try:

    * Reinstalling WP core files
    * Disabling all plugins

    Thanks,
    I have reinstalled WP core files and disabling all plugins… but the error continues appearing, without any clue and randomly.

    1st error)) I thinks wordpress tries to get updates from dashboardl, but can’t stablish connection.. why? I don’t know.
    2nd error) Sorry, It is a plugin error.
    3rd error) It seems a server problem. But it appears after worpdress update, NOT server update.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    How did you reinstall?

    I normally suggest actually deleting wp-admin and wp-includes totally.

    Are you using HTTPS?

    Hello, thanks for your reply πŸ™‚ I have more information about above errors.

    The first problem is that wordpress tries a SSL connection:
    http://api.wordpress.org/core/version-check/1.7/?version=3.8.1&php=5.3&locale=en_US&mysql=5.5&local_package=&blogs=60&users=537&multisite_enabled=1

    But there is a wp response error: SSL connection timeout

    Then successfully retrieve the raw response from the HTTP request using the POST method.

    But, how I can disable wordpress connects to wordpress.org by https? It always gets error.

    By the way, this happens since version 3.7

    Thanks a lot,

    I’m going to open a new thread for 3rd error, as I think they are not linked each other.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    You … can’t. WP is moving everything over to SSL to be more secure.

    Can you install http://wordpress.org/plugins/background-update-tester/ and see what it comes up with?

    Thank you Ipstenu πŸ™‚

    I installed it and get the following results:

    PASS: Your WordPress install can communicate with WordPress.org securely.
    FAIL: The AUTOMATIC_UPDATER_DISABLED constant is defined as true.
    PASS: No version control systems were detected.
    PASS: Your installation of WordPress doesn’t require FTP credentials to perform updates.
    PASS: All of your WordPress files are writable.

    All seems ok… (Automatic updater is disabled as we want.)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘log error since last update’ is closed to new replies.