Support » Plugin: Redirection » Log duration not working ?

  • I set the 404 logs to 1 day but I have entries dating a week back making the log over 11.000 rows….

    Am I missing something ?

Viewing 15 replies - 1 through 15 (of 23 total)
  • And if you set log duration to “no logs” and then refresh the options page, log duration has changed to “forever”…

    And if you set log duration to “no logs” and then refresh the options page, log duration has changed to “forever”…

    Thread Starter Beee

    (@beee)

    Please report your bug in a new topic. Don’t hijack other people’s topics (as per forum rules).

    Make sure your cron job is working. I had the same problem with cron jobs.

    Thread Starter Beee

    (@beee)

    I’m fairly sure that is working… otherwise other processes would also fail imo

    You can verify it by installing this plugin :

    https://fr.wordpress.org/plugins/wp-crontrol/

    Check your cron list in Tools > Cron Events and look at the “next run” column.

    Cron for log delete is “redirection_log_delete”

    Thread Starter Beee

    (@beee)

    I installed the plugin to check. It seems there is no cronjob set for log deletion.

    I just noticed other bugs as well in the plugin.

    Pagination doesn’t show (sometimes) and it only shows max 100 lines where 999 is set.

    Did you try disable and reactivate plugin ?
    It seem cron is created on plugin_activated() function.

    Plugin Author John Godley

    (@johnny5)

    Pagination doesn’t show (sometimes) and it only shows max 100 lines where 999 is set

    Under what context doesn’t it show? The pagination buttons will disappear if there is only 1 page.

    100 items per page is the max. I’ve logged a bug for values more than 100 https://github.com/johngodley/redirection/issues/225

    The cron function should be set whenever you update your options. I have heard some reports of people having problems with the cron, but I’ve never been able to reproduce it. If you continue to experience a problem with it then please do create an issue here and provide some details of your setup:

    https://github.com/johngodley/redirection/issues/

    Thanks

    Thread Starter Beee

    (@beee)

    Hi John,

    I understand the fact of the disappearing pagination. If I go to the 404 logs, I see max 100 lines, even though I set it to 999 in the Screen options.
    This used to work before, now it doesn’t anymore.

    So now when there are less than 999 items, pagination doesn’t show…
    I just deleted them on the live site, but I think I have a backup to make a screenshot from.

    Reg. Cronjobs, this is what shows when I use WP Crontrol

    I also see this error

    Can it be related (to the cron, not to the pagination).

    • This reply was modified 4 years, 2 months ago by Beee.
    Thread Starter Beee

    (@beee)

    PS I did deactivate and reactivate the plugin.

    Do you have any security plugin ? Cloudflare or some other CDN ?

    Thread Starter Beee

    (@beee)

    Only WordFence.

    If the site in your account profile is the same, the problem is you don’t have a wp-cron.php file in your wp root folder.

    Get a 404 when i try to acess to this file.

    Thread Starter Beee

    (@beee)

    I don’t know to which site you’re referring to but every site has a wp-cron.php in the wp root.

    I just moved the wp-root to another place on some sites.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Log duration not working ?’ is closed to new replies.