Support » Plugin: Loco Translate » Loco not working with wordpress 4.6 version

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Tim W

    (@timwhitlock)

    WordPress 4.6 changed the order in which it loads translation files.
    https://core.trac.wordpress.org/ticket/34213

    It now loads from the languages directory first, and author-supplied files are discarded.
    If your translations were being loaded from the theme or plugin itself, then this is the reason.

    However, none of this is the fault of my plugin, because Loco Translate 1.x is not involved in loading your translation files at all.

    Having said all this, version 2.0 of Loco Translate is going live today. Although it can’t undo what WordPress have done, it does offer a priority directory for custom files that will always be loaded first.

    Thanks, Tim. I have installed the 2.0 version but the translations ar still not appearing on production site. What do I need to do to configure it?

    Plugin Author Tim W

    (@timwhitlock)

    Loco doesn’t control the loading of your translation files. If they were displaying with WP 4.5.x but are not displaying with WP 4.6 then it looks like you’re a victim of the change I linked to above.

    Do the translations appear again if you disable Loco Translate? If not then your issue isn’t related to this plugin.

    I found out the issue, my translations were not on the system folder. I’ve fixed that and now it’s working. Thanks for your help

    Love your plugin. Not so with 2.x version… Although the user interface looks better, the real task, finding the pot files and translation files – already made with the 1.x version are not found. Tried 2.0 and 2.02 and went back to the old version.
    How to install 2.x AND be able to find and use the already available translations…?
    After installation the plugin finds some parts: it reads the file produced by the 1.x version only. I know because my translation was only 72% and now it says 100% and all not-translated strings are not there.
    Help!

    Plugin Author Tim W

    (@timwhitlock)

    @basbuis as much as I appreciate your feedback. This thread is about something completely different. If you have a question, could you please open a new topic? Thanks.

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Fabricio

    (@fabriciopassarelli)

    @timwhitlock, please, when I open the translation of woocommerce it does not show anything, just a blank page. Since other pugins, translation is normal.

    What can I do?

    Thank you!

    Hi Tim @timwhitlock,

    I’m using Loco Translate Versión 2.0.11 and Woocommerce Versión 2.5.5 and when I try to translate it to any language I get an “Internal Server Error” msg. Any idea how I can solve this? Attached the screen capture. Thank for your precious time.

    Screen Capture

    Johanna

    (@johannacharpentier)

    Hello, I have the same issue as @contenidoz.
    I get “Error: Internal Server Error” every time I want to save a change in translation.
    Please help ! Thank you.

    In wp-config.php, try increasing the PHP memory limit.

    define( 'WP_MEMORY_LIMIT', '256M' );

    For me 128M was not enough.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Loco not working with wordpress 4.6 version’ is closed to new replies.