Support » Plugin: Loco Translate » Loco automatic translation removes plural translation options

  • Hello Guys,
    I’ve been using the Loco translation plugin to translate my site into polish and added Loco automatic translation plugin.
    I believe there is an error in Loco automatic with plural translations.

    When I view the PO file woocommerce after manually translating it looks like this:

    #. translators: %d: total results
    #: templates/loop/result-count.php:30
    msgid “Showing all %d result”
    msgid_plural “Showing all %d results”
    msgstr[0] “Wyświetlam %d rezultat”
    msgstr[1] “Wyświetlam %d rezultatów”
    msgstr[2] “Wyświetlam %d rezultatów”

    when I use Loco automatic translation the result in PO file looks like this below :

    #. translators: %d: total results
    #: templates/loop/result-count.php:30
    msgid “Showing all %d result”
    msgstr “Wyświetlam wszystko %d rezultatów”

    – and in the result on the frontend – wordpress doesn’t find proper translation and uses english.

Viewing 1 replies (of 1 total)
  • Plugin Author Tim W

    (@timwhitlock)

    I can’t reproduce your problem. Creating a new Polish PO file from woocommerce.pot I enter your plural forms and save the file. They are all there as expected.

    If you have manually created a file, perhaps that’s where your issue is. Please post a download for a file that exhibits this behaviour when edited with my plugin.

Viewing 1 replies (of 1 total)
  • The topic ‘Loco automatic translation removes plural translation options’ is closed to new replies.