Support » Plugin: Seamless Donations » Locks up and never forwards to PayPal

  • Resolved dleifer


    Hi Allen,

    Seamless Donations was working great for us, but testing it today, after a user complaint, I found that after clicking the, “Donate” button nothing appears to happen and you are not forwarded to PayPal. I tried a few things including deactivating, un-installing and re-installing the plug-in, but no improvement. I haven’t added any new plug-ins lately that could be a source of conflict.

    I checked the log and if I click the, “Donate” button and just let it go (you see the animated gif run) the log adds multiple instances of a transaction being started, event though I only pressed the, “Donate” button once.

    02-13-2013 21:12:27 Donation transaction started
    02-13-2013 21:12:27 Name: Bob Smith
    02-13-2013 21:12:27 Amount: 10
    02-13-2013 21:12:28 Donation transaction started
    02-13-2013 21:12:28 Name: Bob Smith
    02-13-2013 21:12:28 Amount: 10
    02-13-2013 21:12:29 Donation transaction started
    02-13-2013 21:12:29 Name: Bob Smith
    02-13-2013 21:12:29 Amount: 10
    02-13-2013 21:12:30 Donation transaction started
    02-13-2013 21:12:30 Name: Bob Smith
    02-13-2013 21:12:30 Amount: 10

    Any help is appreciated.

    The plugin is normally on page:

    but, I think I will be taking it down so look at:

    for now.

    Thank you,


Viewing 11 replies - 1 through 11 (of 11 total)
  • Just a bump with some more information. The site at:

    Still locks up and never forwards to PayPal. I also have a dev site at:

    Password= “password” all lower case,

    where the plug-in works fine. I can’t figure out what the difference is. Same version of WordPress, all the same plug-ins. Could this be a database corruption issue?


    I took a look and I see what you mean – I don’t know what would be in my code that would cause repeated calls like that – the posting to the backend – I do see at least one plugin emitting javascript for that page besides seamless donations – would you try disabling all other plugins first and see if the problem goes away?

    Don’t forget to clear your browser’s cache after turning off all the plugins so you don’t accidentally test with cached javascript.

    Then, re-enable them, one at a time, and let me know if a particular plugin causes the problem to begin again.


    Thanks for looking into this Allen.

    I disabled all the plugins including Seamless Donations and cleared my cache. I could easily see the effect of the other plugins not being active. I then un-installed Seamless Donations. Then reinstalled and activated Seamless Donations and no other plugins. Same problem the only plugin active being Seamless Donations. Pretty odd! And again the dev site with the full set of plugins is still working fine.

    I am stumped.

    I needed to reactive all the needed plugins for the live site so you can’t see it with only Seamless Donations active now.

    One last thought. Even after completely un-installing and then reinstalling, when I activate the plugin I still have all the same settings (PayPal gateway, text of the Thank You Letter) appear. I assume this is because this information remains in the database. Would there be any reason for me to try uninstalling the plugin and then manually removing the associated data? I am far from a DB admin, but I can look through the MySQL tables if you gave me a few hints of fields to find and remove. Or is this too dangerous and not really worth trying?


    Was this issue ever resolved? I’m having the same exact issue.

    I also tried the deactivating of all other plugins, but like dleifer, that didn’t help. After clicking “Donate”, I see the little animated boxes that show that the program is working, but it never takes me to the thank-you screen. The Seamless Donation Log shows the message “Donation transaction started” every second, but never resolves. After several minutes, I ended up just closing the browser window. Nothing ever appeared in my Donations or in Paypal.

    I tested in IE 10 and Firefox 20…got same results in each.

    This plugin looks PERFECT for my purposes, but just doesn’t work. Help?

    Hi Allen,

    The same problem that is mentioned previously, in my case after make click in donate button, it just appear the animation and nothing else, in log file appears the message: Donation transaction started. Can you help us with these please?

    Hmmm…. I am rewriting this part of the plugin to work differently – I am stumped as to why the calls are working correctly on some hosts and not others, but I have a couple ideas.

    A new version will be available this month – sorry for the delay – I’ve been swamped.

    OK – just to let everyone know at least one way to get the “click on donate and the processing graphic just goes and goes and goes” problem is if you have bad HTML in the page on which you have placed the dgx-donate shortcode.

    To see if this is a problem, go to your dashboard, Edit the Page, and switch to Text mode on the editor. If you have anything in the text editor other than the shortcode


    then carefully make sure that all HTML tags (e.g. <b>Bold</b> ) are properly closed and don’t put the shortcode inside any tags.



    dleifer – from looking again at your first site, I think you’re having the same issue – please examine the HTML for that page in the editor and I think you’ll find the culprit there – see the instructions above

    allendav – you nailed it! I removed all my HTML code (as a test) and just left the [dgx-donate] shortcode. Sure enough, the Donate button now works! …now to gradually add my HTML back and figure out where it went bad.

    Thanks for troubleshooting this! I love this plugin!

    Glad to help!


    A quick test seems to show that, having taken your suggestion to clean up the HTML, all is well again. Thank you!

    Any progress on adding a feature where you can designate a particular fund/sub-fund/area for the donation? I saw the idea on a few threads, and a while back I thought you had mentioned considering it and some other add-ons and making a pay plug-in. I am happy to pay for a plug-in with that feature if you ever get to it.

    And I hope the standing at work is still working. Thanks again.


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Locks up and never forwards to PayPal’ is closed to new replies.