Support » Plugin: User Access Manager » Locking files still allow direct download via URL

  • To whom it could help me,

    – I have activated the files locking system,
    – I have verified that the HTACCESS could be modified
    – I have activated the permalinks
    – I have created groups
    – I have have assigned pages and posts to these groups for only logged in user to be able to see the pages. Ex: https://www.lfkl.edu.my/governing-bodies/?lang=fr
    That works very good.
    – I have assigned PDF (media) to restricted groups (groups that need to be logged to get access to the files). I have also attached the PDF to the pages that are locked. I have done it in the 2 languages of the website. I have assigned the PDF to categories that have restricted access.

    But anyone can still access this file via URL: https://www.lfkl.edu.my/governing-bodies/?lang=fr

    QUESTION: any leads on where the problem could be?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • jfk105

    (@jfk105)

    Same to me. Same steps done by Matzinck, but same wrong behaviour.

    I try this with a local copy of my production site and here it works (WHY?) (When I try to open a a pdf’s protected link it correctly reports that I can’t read it).
    But on production site the behaviour is still wrong. I can open all protected files if I try with own links…
    I check .htaccess (on primary root of WordPress and under Uploads) and they have same permissions on local and on production site.
    I don’t know why online isn’t working…
    Unfortunately I can’t update (local or online same behaviour) UAM plugin as reported here: https://wordpress.org/support/topic/upgrade-to-2-1-2-wont-save-users-role-and-all-post-access-switched-to-free/
    Anyone can help us?
    Thanks in advance
    J

    With my isp support I found a solution.
    The issue on online server is with a Ngix cache on the server that tries to serve static documents instead of dynamical document.
    So we need to check into “Serve static files directly by nginx” documents types and remove those files we need to restrict (pdf and zip in my case).
    After we removed pdf and zip types from the list now if I try to open direct link to protected pdf/zip the page reports correctly a notification that the document is reserverd.
    If you need to protect all types maybe you can disable the ngix cache, but this I can’t tested.
    Hope this helps someone!
    Ciao
    J

    • This reply was modified 3 months, 3 weeks ago by jfk105.
    • This reply was modified 3 months, 3 weeks ago by jfk105.
    Thread Starter matzinck

    (@matzinck)

    Thanks a lot for the help and the feedback.
    We have looked into it and indeed that could have been one issue but we also saw another one, is that the function was not working when in UAM-> Settings-> File Settings -> we selected as “Locked file types”, “File types not to lock:….”. Once we have moved this parameter to “All”, it worked.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.