locked out, restore not working.. (7 posts)

  1. paperlion
    Posted 11 years ago #

    Moved WP (1.2.2) to a new host - same type Linux/Apache server setup, but PHP, MySQL, etc. versions may be slightly different - both PHP 4x though.

    I deleted all tables from the DB and then restored the site via PHPmyadmin with a success announcement afterward. Yea so far.

    As user passwords were with this restore, I had to use the Retreive Password routine by fishing in the DB tables and encrypting another one using MD5. Afterward though, wp-login.php takes me to a blank page though - won't let me in.

    FWIW, this didn't work on the old server either when we tried changing the passwords there, had very similar problems there too. Actually, on the previous server none of the 9 or 10 users could log in - it wasn't just one of us. I didn't check on the new install for the same level of this problem.

    Is anything else likely to be corrupted? Clicking the admin panel link just after Step 3 of the install left me hanging. Trying to login from the homepage also brought me to the wrong area.

    Thanks everyone...

  2. James Huff
    Support Team Rep.
    Posted 11 years ago #

  3. paperlion
    Posted 11 years ago #

    Great. One-Down...

    I had *partially* changed the etc/hosts file to include the domain I am working on and to keep the computer from looking in the actual dns table.

    (I only added the http://domain.com to the document, without the www prefix though). This got me in trouble since the sql dump file apparently references the www version of the domain name AS WELL AS the one without the www. Thus one major hurdle mostly solved.

    Thank you macmanx and everybody!!

    However, I log in with a fresh password and a message will appear on the screen saying "Your Session Has Expired". This repeats with every attempt. Looked through the posts and didn't notice anything close enough to this that wasn't tried, but sure hope someone has some leads.

    Oh, yea. Was getting permissions errors from the standard settings, and had to remove owner write abilities for key files - all the way down to 444 (reads for all, but that's it)!


  4. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Woa, that's way to low. They need to be at least 644. Read this: http://codex.wordpress.org/User:Podz/Permissions

    If you still can't login, read this: http://codex.wordpress.org/Login_Trouble

  5. paperlion
    Posted 11 years ago #

    I just remembered that nobody is able to login.

    Also, the login link at the homepage (index.php) generates a blank page, but with refresh, brings up the dialog.

    With the login dialog box, a known bad password brings up the password error dialog, but a good user/pw combo brings up a blank screen with the following uri:


    Permissions are set to 644 throughout, and 755 for folders (664 generates some 500 errors for excessive writes enabled).

    Is there anything telltale in this?

  6. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Your site_url is set wrong. You'll have to manually change it.


  7. paperlion
    Posted 11 years ago #

    You're right, macmanx!

    Although I had copied all the settings when relocating the blog to a new server, I didn't bother adding the index file to the root folder for domain name access, since I figured I would do that later. Well, there it was being referenced in the site_url settings as existing in the root. Adding it there made all the difference.

    thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.