• awakegal

    (@awakegal)


    I installed User Switching plugin and when I switched to Editor Role, I got a page that says

    Sorry, you are not allowed to access this page.

    Now I cannot get into the dashboard.

    I deleted the User Switching plugin from the filemanager.

    How do I access the dashboard?

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nintechnet

    (@nintechnet)

    I cannot reproduce the issue: I created an Editor user, installed the plugin and switched to that user and it worked as expected.

    What error do you get when you access your /wp-admin/ URL?
    Did you try to delete your cookies?

    Thread Starter awakegal

    (@awakegal)

    Yes, I cleared the cookies

    When I try to login I get this message:
    Sorry, you are not allowed to access this page

    And the email I received from Ninjafirewall says:
    NinjaFirewall has blocked an attempt to modify a user capability by someone who does not have administrative privileges:

    Blog: https://website.com/
    Username: xxxxx, ID: 2
    meta_key: wp_sw_capabilities
    meta_value: a:1:{s:6:”editor”;b:1;}
    User IP: 161.97.232.163
    SCRIPT_FILENAME: /home/customer/www/website.com/public_html/wp-admin/plugins.php
    REQUEST_URI: /wp-admin/plugins.php?charsout=370&plugin=wp-user-role-switcher%2Fwp-user-role-switcher.php&plugin_status=all&paged=1&s&action=role_switcher&role=editor&nonce=688cd274b7
    Date: April 29, 2021 @ 11:46:27 (UTC -0700)

    A PHP backtrace has been attached to this message for your convenience.

    This protection (and notification) can be turned off from NinjaFirewall “Firewall Policies” page.

    Plugin Author nintechnet

    (@nintechnet)

    There’s something that triggered the privilege escalation protection of the firewall. A script wanted to modify your capabilities.
    Try first to temporarily disable the protection by adding this line to your wp-config.php script:
    define('NFW_DISABLE_PRVESC2', true);

    Then try to log in.

    Thread Starter awakegal

    (@awakegal)

    I added the code to wp-config.

    I can log into the website as now there is a black bar above the website, however I cannot access the dashboard.

    Perhaps I should uninstall Ninjafirewall?

    How would I do this manually via ftp?

    Thanks.

    Plugin Author nintechnet

    (@nintechnet)

    You can rename its folder (/wp-content/plugins/ninjafirewall).
    After, you could remove the NFW_DISABLE_PRVESC2 directive from the wp-config.php.

    If that doesn’t work, you may need to disable all plugins one by one. But it seems to me that your account is somehow corrupted (wrong user role or missing capabilities).

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.