WordPress.org

Forums

WordPress HTTPS (SSL)
Locked myself out of dashboard, tried resetting plugin both ways, not working! (10 posts)

  1. davidg333
    Member
    Posted 1 year ago #

    Hello,

    I think I accidentally forced SSL on my site trying to use a shared certificate from my host, and now I have locked myself out of the admin panel.

    http://www.wakeupbefree.net/wp-admin

    When I sign in it just redirects back to the sign in page again.

    I have tried both to reset the plugin through both the Go to /wp-content/plugins/wordpress-https/wordpress-https.php and wp-config.php files, but it's not working.

    Any ideas to help would be awesome!

    Thanks,
    David

    http://wordpress.org/plugins/wordpress-https/

  2. Lindsayloub
    Member
    Posted 1 year ago #

    Hi David,
    I am experiencing the same problem. Did you find a solution?
    Thanks,
    Lindsay

  3. davidg333
    Member
    Posted 1 year ago #

    Hi Lindsay,

    Unfortunately not. There are some other threads on the same thing though if you search around (don't have the links sorry), but I couldn't get anything to work and ended up wiping the site out and then cleaning off wordpress completely and restoring.

    I've just purchased an SSL certificate and static IP from my webhost now which seems to be working without the plugin.

    Thanks,
    David

  4. Lindsayloub
    Member
    Posted 1 year ago #

    Clearing the browser cache just worked for me. Shame they didn't tell you to do that in the plug-in FAQ. Would have saved me hours of worry.

    Glad you managed to find a solution. I have an SSL cert from my host, but when I force SSL on the general woocommerce settings it won't let me complete the checkout process, which is why I downloaded this plug-in in the first place.

    Not really sure what my next steps are.

    Thanks for replying to me.
    Lindsay

  5. Walter479
    Member
    Posted 1 year ago #

    Beats my two pair - I just installed the SSL and then 'saved' it, I believe also using a Forced SSL and now cannot log in to my admin page. I also tried clearing my cache (Firefox) to no avail. Any ideas?

  6. Lindsayloub
    Member
    Posted 1 year ago #

    1. Clear your cache on all of the browsers you use, so that maybe internet explorer, mozilla and google chrome

    2. Now, find the php file 'wordpress-https.php'.

    3. Find the line:
    //define('WPHTTPS_RESET', true);

    If you find this, then delete the // to make it:
    define('WPHTTPS_RESET', true);

    Save this change, and then try and access some of the pages on your website

    5. Try to log in to the admin panel now

    6. Fingers crossed you should be able to log in now

    7. Go back to 'wordpress-https.php' and put the two // back in so that it is again commented out and save.

    8. Clear the cache, clear recent browser history, close the browser altogether.

    9. Re open the browser, and try to login to the admin panel.

  7. Walter479
    Member
    Posted 1 year ago #

    I had to contact my tech support at hosting and have them 'restore' a previous save in order to get back in. WHEW! Kinda like restoring your computer to a previous point. Won't go there again.

  8. neoikon
    Member
    Posted 1 year ago #

    Lindsayloub,

    Thank you for the suggestion. When I try and access my page, it still tries to re-direct to HTTPS and fails to work.

    Where can I manually disable this redirect? I already did your suggestion above.

    Thank you!

  9. aled2305
    Member
    Posted 1 year ago #

    Have you tried renaming the plugin folder from

    /wp-content/plugins/wordpress-https

    to

    /wp-content/plugins/wordpress-https-1

    This might (usually) make wordpress disable the plugin and resolve you login issue.

    Good Luck

  10. neoikon
    Member
    Posted 1 year ago #

    Thank you for the reply. I kept getting an "access denied" when trying to rename the folder.

    However, renaming the "wordpress-https.php" file allowed me to effectively disable the plugin.

    Prior to doing that, I un-commented the "reset" line within the file (then hit a page to run it). I don't know if a combination of the two allowed me access again, but I am back in.

    It's disappointing. I'd really like to get this working...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.