WordPress.org

Forums

Locked me out my own site (9 posts)

  1. Kadr
    Member
    Posted 5 years ago #

    HEy.

    After trying to increase my sites security yesterday with the help of this article: http://codex.wordpress.org/Hardening_WordPress

    But now I am locked out of my site.
    Changed too many permissions I guess...

    Can someone tell me how to get back to the default settings?

    thnx
    Kadr

  2. Samuel B
    moderator
    Posted 5 years ago #

    depends on what you did
    if you put an .htaccess file in the /wp-admin folder rename or delete it
    otherwise, what were you doing?

  3. Kadr
    Member
    Posted 5 years ago #

    hey, thnx for the reply

    I was just trying to get all the permissions in accord with the document referred to above.

    the .htacces file is still in the same place.

    Other then that, I was tinkering around so much, that I can't recall exactly what I did that made things go wrong. therefore I just want to check all the files and directories and make sure they are correct. Therefore I'd need someway to know what they are supposed to be...

    Maybe I need to have a decent, default piece of code as well to paste into the .htaccess file again...

  4. Samuel B
    moderator
    Posted 5 years ago #

    delete the .htaccess totally
    if things are back to normal, regenerate your permalinks
    admin - settings - permalinks

    did you install this plugin?
    Caution: Installing the AskApache Password Protection plugin may lock you out of your WordPress Admin panel and return an error 500 when you attempt to go to yourdomain.com/wp-admin. You might try installing the plugin on a test site first, as your server or other configurations may cause issues. To uninstall the plugin, first delete the new .htaccess file that appears inside your wp-admin folder. Then log in to your site and deactivate (and then possibly delete) the plugin. See the comments under the author's plugin home page to read other users' experiences with this plugin.

  5. Kadr
    Member
    Posted 5 years ago #

    thnx Samboll.

    I deleated the .htaccess file.
    And in an attemtp to have at least acces to my sites, I set th permissions for all files to 777.

    It generates this error now:

    Warning: require(/domains/kadr.nl/wordpress/wp-includes/compat.php) [function.require]: failed to open stream: Permission denied in /domains/kadr.nl/wordpress/wp-settings.php on line 246
  6. Kadr
    Member
    Posted 5 years ago #

    ah what. Interesting if you can let me know what happened. But I think I just have myself a reinstall...

    I can do this because I haven't even properly started yet with the site. Though, maybe for later reference, it would be cool if this is resolved for people who are already several years on their way with their site and get locked out...

  7. Samuel B
    moderator
    Posted 5 years ago #

    /wp-includes/compat.php
    error says you're missing this file

  8. webrob
    Member
    Posted 5 years ago #

    Did you find out how to fix this error:

    Warning: require(/domains/kadr.nl/wordpress/wp-includes/compat.php) [function.require]: failed to open stream: Permission denied in /domains/kadr.nl/wordpress/wp-settings.php on line 246

    I am having the same issue now.

  9. webrob
    Member
    Posted 5 years ago #

    And I am NOT missing the file. Both files are there.

Topic Closed

This topic has been closed to new replies.

About this Topic