Support » Plugin: Freesoul Deactivate Plugins » Lock in the elementor model editor

  • Resolved Bradock

    (@valberfigueiredo)


    Hello Jose, how are you?

    Can you give me strength please?

    I noticed that Freesoul Deactivate Plugins plugin access to my elementor editor.

    Although apparently everything is active for the elementor plugin, I still have this restriction and I don’t know the exact location because I must have configured some location that is deactivating my elementor editor.

    When I go to elementor in> Templates> Saved Templates> and click> Edit with elementor

    I get a white page with a pop-up with warning:

    No permission to access this page.

    So I disabled your plugin and was able to access it without any problems.

    So I thought about creating a link rule:

    https://mysite.com/wp-admin/post.php?post=16363&action=elementor

    I would like help. To create a rule with a URL above, where should you create this rule in the Freesoul Deactivate Plugins plugin?

    remembering that the url above it changes post ID code according to post.

    Or would you have an idea of ​​the location that should be active in the plugin that is blocking the elementor editor?

    Would you help me?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jose

    (@giuse)

    Hi @valberfigueiredo

    I’m fine thanks, I hope you are fine too.

    I see 2 probable causes:

    – You have a rule in Backend => Backend URLs that is disabling Elementor on the Elementor editing page
    – The nonce related to the Elementor editing page was expired. Then you disabled FDP, you tried again with a newly generated nonce and it worked, but FDP had nothing to do with the issue

    (If you need more explanations about nonce, you can read here: https://codex.wordpress.org/WordPress_Nonces)

    I suggest the following:
    – check the rules in Backend => Backend URLs
    – try again with FDP enabled. First, refresh the page that includes the Elementor button “Edit with Elementor”. Click on that button after the page is refreshed. If it still doesn’t work, we can exclude that the issue was caused by an expired nonce

    In any case, for this kind of editor pages, you can control the plugins with the options you find at

    Backend => Backend URLs

    Use this expression:
    *wp-admin/post.php?post=*&action=elementor*

    The star replaces groups of characters.

    Be careful, what you see in the Elementor editor page, is a frontend page included in an iframe of a backend page.

    Inside the iframe, you have a page and you can manage the plugins of that page as usual.

    I’ve tested Elementor with FDP and hadn’t this issue, but if you still have problems after the suggestions above, let me know.

    Bradock

    (@valberfigueiredo)

    Thank you Jose.

    I tested on nonce that you told me.

    And problem followed.

    Then I did the other test by inserting url in:

    Backend => Backend URLs

    The URL rule you sent me:

    *wp-admin/post.php?post=*&action=elementor*

    It also didn’t work.

    I cleared the cache and updated it to 2 cases above and it didn’t solve it.

    I can solve the problem just by deactivating your plugin.

    But I don’t want to disable it.

    Plugin Author Jose

    (@giuse)

    Hi @valberfigueiredo

    you are welcome, thank you for the information.

    Don’t worry, in a way or in another we will solve the problem.

    Is this issue on the same site where you had other issues?

    If so, copy the content of this file: https://plugins.svn.wordpress.org/freesoul-deactivate-plugins/tags/1.7.7/mu-plugins/eos-deactivate-plugins.php

    Then connect via FTP and paste the copied code in wp-content/mu-plugins/eos-deactivate-plugins.php

    Let me know if it works.

    Bradock

    (@valberfigueiredo)

    Yes … José on exactly the same site as that.

    I’m sorry for this.

    Because I don’t know if it’s some configuration I made in the freesoul plugin that caused this. But I do not think so.

    Because with the pages created with elementor I can access the editor normally and edit the pages without problems.

    Only with> Saved models> with elementor do I have this problem.

    I tested it as it sent me in:

    wp-content / mu-plugins / eos-deactivate-plugins.php

    And it didn’t. I cleared cache and nothing for now.

    If you need to investigate by accessing my dashboard. Tell me.

    Thank you again.

    Bradock

    (@valberfigueiredo)

    Hello José, how are you?

    I found another plugin without permission to access the plugin options.

    This is also happening in the plugin:

    The Plus Addons for Elementor Page Builder

    When I go to:

    The Plus> Settings and I click on any option.

    I receive a page with a white box with a message:

    No permission to access this page.

    This is an url without permission: https://mysite.com/wp-admin/admin.php?page=theplus_options

    All url for options of this plugin only change the end of the link

    So I created the following rule:

    *wp-admin/admin.php?page=*

    and inserted in:

    Backend> Backend Urls

    And I did it. And I was able to access the plugin options again.

    Or if you don’t create the rule above.

    Another way to get back to accessing plugin options is to disable the Freesoul Deactivate Plugins v1.7.7 plugin and clear the cache.

    And normal back access.

    And I also activated a plugin:

    Query Monitor

    And he informed me this code on the page without permission link above:

    Query Monitor

    The message above was triggered by Core.

    Call stack:

    wp_die ()
    wp-admin / includes / menu.php: 350

    I do not know what it means. But it must be about the problem.

    In other words, in the elementor plugin by going to> Templates> Saved Templates and clicking> Edit with Elementor.

    It basically happens the same thing.

    I get a blank page with a pop-up warning:

    No permission to access this page.

    But in this case, creating a rule with a URL didn’t work.

    I am informing you about this other plugin because The Plus provides Addons that complement Elementor.

    And somehow this must have some connection because for the time being I noticed this problem only with these 2 plugins.

    – Elementor

    – The Plus Addons for Elementor Page Builder

    I spent the day tweaking the Freesoul Deactivate Plugins v1.7.7 settings, to see if it was any of my settings that was causing this.

    But I think it’s not in my freesoul settings, I think it’s something else that I don’t have the intelligence to discover and normalize.

    When you see it, it might be something I missed. But if it is, I don’t know where!

    I hope I helped you, José. If I can do something to help you, please tell me.

    Thank you for all your heart effort.

    Plugin Author Jose

    (@giuse)

    Hi @valberfigueiredo you already know, this is just to inform other users who may have the same problem.

    On the Elementor Templates editing page, Elementor loads a backend page that includes an iframe of the homepage.
    The source of the iframe is something like https://your-website.com/?elementor_library=template-example&elementor-preview=xxxxxxx.

    This means that if you disable Elementor on your homepage, the Templates editing page will not work.

    The next version of Freesoul Deactivate Plugins will solve this issue without the user need to do anything. Until the new version is public if you need to disable Elementor on the homepage, you should add this custom URL in Custom URLs => Fronted URLs:

    *?elementor_library=*

    For that custom URL, enable Elementor. This will override the settings of the homepage.

    About the problem with The Plus Elementor Add-on, that plugin was disabled in Backend => Backend Singles. So this was a matter of settings.

    Bradock

    (@valberfigueiredo)

    Thank you José.

    With The Plus I was careless on my part. Still learning to configure in a 100% correct way, because I believe that in my freesoul settings I still have things that I could disable and because I don’t know if I should disable it, I haven’t yet disabled it and sometimes I disable things in places that I shouldn’t.

    Thank you very much Jose problem successfully solved. You are incredible.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.