Support » Plugin: WP User Manager - User Profile Builder & Membership » Lock access to wp-login

  • Resolved gpatters

    (@gpatters)


    Hi,
    Locking access to wp-login.php (Users->Setting->General->Login Settings) is not working.

    The checkbox is checked, however users are not redirected to the WPUM login page and can still login via wp-login.php.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Alessandro Tesoro

    (@alessandrotesoro)

    Hi @gpatters

    Have you made sure you selected a login page in the plugin’s settings as explained here https://docs.wpusermanager.com/article/56-login-page-setup ? If so and the issue persists, something else on your site is hijacking that functionality.

    Disable all other plugins one by one to see who’s causing the issue.

    Thread Starter gpatters

    (@gpatters)

    Thanks for the quick reply Alessandro.

    Yes, the wp user manager’s login page is set up. That part is working as expected.

    I have also set up the backend redirects – that also works.

    Re disabling wp-login….
    I disabled the plugins one at a time and then all at a time. It made no difference. I can still access and sign-in via wp-login.php.

    Not sure if it makes any difference – our wordpress is in a sub-directory not directly in the root.

    Plugin Contributor Alessandro Tesoro

    (@alessandrotesoro)

    Hi @gpatters

    Apologies about the issue, I managed to replicate the issue on my end, I couldn’t previously because I was testing something else.

    I’ll fix the issue in the next update, I’ll be releasing one next week 🙂

    Thread Starter gpatters

    (@gpatters)

    Thanks Alessandro.

    While you are at it any chance of correcting the disable/enable upload of user profile image?
    See this topic.
    (We’ve applied the work-around you gave in the reply.)

    Plugin Contributor Alessandro Tesoro

    (@alessandrotesoro)

    This has now been sorted, a new update has just been released.

    Thread Starter gpatters

    (@gpatters)

    Hi Alessandro,
    Unfortunately the new version has a problem.

    Note: Have disabled all other plugins and set Twenty Nineteen theme.

    Users cannot log in from the front end via WP User Manager login.
    It seems they can log in the 1st time however if the user logs out, then they can’t log back in. It shows the message:
    “Error: The password you entered for the username xyz is incorrect. Lost your password?”
    If the user then goes to wp-login.php then they can log in with the same credentials so it’s not a problem with username/passwords.

    Haven’t been able to fully test “Lock access to wp-login.php” as I end up being locked out of the system due to the above.

    OTOH the options to enable “Custom Avatars” and enable “Disable Profile Cover Image” are working. (Enabling a disable makes the purpose of that latter option a bit obscure…:-))

    We didn’t keep the previous version of the plugin. Is that available anywhere for download and re-install?

    Thread Starter gpatters

    (@gpatters)

    Quick update: found the old versions under Advanced View.

    Plugin Contributor Alessandro Tesoro

    (@alessandrotesoro)

    I’ve retested it multiple times on my end but I can’t replicate the issue. Mind emailing me at support@wpusermanager.com so I can have a closer look to your website?

    Thread Starter gpatters

    (@gpatters)

    Hi Alessandro,

    On rechecking this morning I found a browser stored credentials issue. It was reverting to an older stored password for the WP UM Login page but was using the correct password for the wp-login page. Not exactly sure why.

    Have removed the old credentials and have been able to log in and out repeatedly. Which is good!

    So for anyone else encountering a similar issue, good idea to double check what is stored in the browser – what appears to be identical credentials may not be.

    Thanks for your offer of assistance – much appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Lock access to wp-login’ is closed to new replies.