WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Locations and 404 error

[Resolved] Locations and 404 error

  • Antonio
    Member

    @sonorobit

    Events Manager version 5.3.1.

    I know this problem has to do with my theme, I am using directorypress from premiumpress. I would like a best advice.

    Eveything runs ok except for the single location page. It is throwing a 404. I have done the following

    Changing my permalink structure (all options tested)
    Changing the type of location (page or post)
    changing the slug (not working either, cant change it to other than ‘location’)

    I am reluctant to go to the code but I will do it if I have to, I just need advice as to what to look for and what to test.

    Thank you

    http://wordpress.org/extend/plugins/events-manager/

Viewing 10 replies - 1 through 10 (of 10 total)
  • agelonwl
    Member

    @angelonwl

    Hi,

    how about if you create brand new pages and assign those as new event pages? you can call them whatever you want to begin with, reassign them in EM settings, and test them out, just to see if it works.

    Then, you can rename the slugs etc. of these pages and make them children of the events page, hopefully it’ll still work.

    Plugin Author Marcus
    Participant

    @netweblogic

    changing the slug (not working either, cant change it to other than ‘location’)

    why is this not working? what happens when you try to change it?

    Antonio
    Member

    @sonorobit

    @agelonwl, will do and report back.

    @marcus, I change and save, everything ok, but when I go to an event (from the Events listing within WP admin) the URL keeps pointing to the previous slug. Click the link, I am able to see that no problems, go to the location link and it still shows again the previous slug.

    Antonio
    Member

    @sonorobit

    sorry, forgot to add, if I type the new slug directly in the URL bar, it will not work.

    Antonio
    Member

    @sonorobit

    Some more information

    Changing the slugs for events (an I assume categories also) its working.

    But for locations it is not. I think this is related to the problem with the 404 I am getting. If I change the slug to something else, the links for locations won’t reflect it. If I type it directly in the URL bar it will revert to the “location” slug.

    I am willing to let someone with knowledge access my test site as admin and check it out.

    Antonio
    Member

    @sonorobit

    Oh by the way, agelonwl, I changed the pages but it didn’t make any difference.

    Plugin Author Marcus
    Participant

    @netweblogic

    so are locations basically not working regardless of the slugs you assign it?

    Also, if your new slugs aren’t being updated/reflected in your links, could it be because you have a caching plugin enabled?

    Antonio
    Member

    @sonorobit

    Hello Marcus, no, I have no caching plugin activated. I resorted to just not having locations link anywhere on site, I had to put the location information in the single event post.

    Getting the same problem with the location page throwing a 404, if I change to a standard theme all works well but once I go back to directorypress theme the location page goes again, I would really appreciate a fix for this.

    agelonwl
    Member

    @angelonwl

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Locations and 404 error’ is closed to new replies.