localized Mac os X Mysql restore timing out (3 posts)

  1. edfladung
    Posted 9 years ago #

    Hi Guys,

    My database backup file is 42mb. I've downloaded it, to create a local version of my blog running on Mac OS X. I've got MySql and PHP playing nicely. But I can't import the file using PhpMyAdmin (file size limit) and I can't do it with CocoaMySql either (same reason). So I tried my hand at Terminal app with the help of the tutorial here. My back up file (backup.sql) is in my top level directory of my G5. when I run the command to MySql I get an error telling me the command doesn't exist:

    eds-g5:/ Ed$ cd usr/local/mysql/bin
    eds-g5:/usr/local/mysql/bin Ed$ mysql -u root edwpdb < ../../../../backup.sql
    -bash: mysql: command not found
    eds-g5:/usr/local/mysql/bin Ed$

    same error here:

    eds-g5:/ Ed$ cd usr/local/mysql
    eds-g5:/usr/local/mysql/bin Ed$ mysql -u root edwpdb < ../../../../backup.sql
    -bash: mysql: command not found
    eds-g5:/usr/local/mysql Ed$

    Does anyone have experienced with localized versions of wordpress running on macs? i figure it's my noobness with Terminal App, but any hints I would be much appreciated.

  2. misionpilot
    Posted 9 years ago #

    Hi I have had a simular problem and would like to know if anyone has had any success... I am new to SQL and am having idfficulty getting CocoaMySQL to be able to read my .sql file. it is only 10.8Mb but I would like to know if there is a comand line way to do this...
    I got WordPress 2.0.5 to run so apache, php 4.4.1, and MySQL 4.1.21-standard are all playing nicely on Tiger 10.4.8. on a Powerbook G4. I just cant figure out how to import the MySQL data.

  3. edfladung
    Posted 9 years ago #

    I finally realized that my 42mb sql file was mostly from a plugin that was caching huge amounts of info to my mysql file. i dumped those tables and got the file down to 7mb.

    I still couldn't get phpmyadmin to load the sql file. i finally just upgraded to wp 2.0.5 and used the db backup plugin to create a backup copy of the file and used that instead.

    and it worked!

    To this day, the only way i can get restore a backed up file is to use the back up plugin that comes with the default install of WP.

Topic Closed

This topic has been closed to new replies.

About this Topic