[resolved] Localization not working (2 posts)

  1. handig
    Posted 4 years ago #

    I'm having problems with localization. If I have
    define ('WPLANG', 'nl'); it works but if I use 'the standard' define ('WPLANG', 'nl_NL'); it doesn't localize.

    If I change from nl to nl_NL I change the language files of the theme accordingly. So this isn't the problem.

    I found these old links:
    - this link that refers to some php.ini server settings as the cause
    - And this links says the server cannot read the .mo file so it loads default english captions.. It concludes that there´s an issue with the gettext library and wordpress running on x64 based machine. Basically it´s a byte addressing issue regarding the language files located at wp-includes/languages. And it should be solved with the later WordPress releases.

    But I'm on 3.1.2 and the language setting nl_NL doens't work, while nl works. What can it be?

  2. handig
    Posted 4 years ago #

    I had a clear moment. I placed a new copy of the translation files on the server and it worked. Seems like the files were corrupted somehow.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.