WordPress.org

Forums

Zxcvbn
[resolved] Localization Issue (3 posts)

  1. Jonathan Desrosiers
    Member
    Posted 1 year ago #

    Noticed a bug with this. Because you are deregistering the script, the strength responses are missing and causes JS errors. You just have to add a wp_localize_script call. Below is the one used in core.

    wp_localize_script( 'password-strength-meter', 'pwsL10n', array(
    	'empty' => __('Strength indicator'),
    	'short' => __('Very weak'),
    	'bad' => __('Weak'),
    	/* translators: password strength */
    	'good' => _x('Medium', 'password strength'),
    	'strong' => __('Strong'),
    	'mismatch' => __('Mismatch')
    ) );

    http://wordpress.org/plugins/zxcvbn/

  2. Samuel Wood (Otto)
    WordPress.org Tech Dude
    Plugin Author

    Posted 1 year ago #

    Cool, thanks for the info. I'll add it shortly.

  3. Samuel Wood (Otto)
    WordPress.org Tech Dude
    Plugin Author

    Posted 1 year ago #

    Fixed in version 1.1 of the plugin. Good catch! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.