WordPress.org

Forums

Localhost, Subdomains, Permalinks, htaccess (2 posts)

  1. MikeLesser
    Member
    Posted 9 years ago #

    Kind readers: I've already set up a bunch of blogs (thanks to your generous efforts) that include fancy permalinks, run on subdomains, and on remote servers as well as on localhost, but now I've run into a snag.

    I just set up my first subdomain on localhost and created a blog. It's all fine, except that the fancy permalinks don't work.

    I get a generic 500 error, and I have to assume that the htaccess is being ignored. I'm really a noob with Apache, so besides looking at the log and using apachectl I'm reduced to trial and error.

    The subdomain was set up with VirtualHost and works fine. My http.conf has the 'permalink fix' a la:
    <Directory "path to blog" >
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    The entire web directory also has "AllowOverride All", and just for kicks, I've even done this bad thing:
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    My wordpress directories .htaccess files are just like they are on my remote blogs, and my prior (pre-subdomain-creation) local blogs:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    Naturally it could be anything, I'm just guessing it's the .htaccess. Any ideas? TIA
    Mike

  2. MikeLesser
    Member
    Posted 9 years ago #

    Aha! I solved it: my rewrite rules were wrong!

    For those who have similar problems, there is a way to diagnose this stuff easily. You can log the errors from the httpd.conf using

    RewriteLog "/tmp/filename.log"
    RewriteLogLevel 5

    Any value up to 9 is fine; 5 is more than enuf. It's quite verbose. My problem was that the htacess rules appended an additional directory onto the path.

Topic Closed

This topic has been closed to new replies.

About this Topic