Support » Localhost Installs » localhost site running very slow on a XAMPP installation

  • Resolved Eddie_E

    (@eddie_e)


    Hi, I just had to upgrade my xampp and now the localhost takes around 10 seconds at a time to refresh. All sites that are not wordpress based run fine! Any ideas for a fix?

    Cheers

Viewing 13 replies - 1 through 13 (of 13 total)
  • Is there any chance you had added some tweaks to the former Xampp that have now been replaced or over-written?

    Also: I have different versions of Xampp in WinXP and Win7, and there is definitely some kind of database difference somewhere. So on that thought, I might try exporting a backup of what you presently have and then dropping all the tables and re-importing the backup to see whether that might help. However, you might first have to tweak php.ini for accepting a large upload if that database is much larger than a fresh one.

    No I didn’t make any tweaks to the last… I only updated as I got an error importing the database that I began on my windows version of XAMPP as it was running on a newer SQL… I will try what you suggested thx! The database is very minimal, its a small basic site!

    Another way you may want to troubleshoot this it to try a different local server. I have tried most of the popular ones but the one I have used as my go-to local server since 2009 is the Uniform Server. Perhaps give it a try and compare the speeds.

    I’m on my imac when it runs slow, when running on my windows server it runs how it should (about 2sec delay apposed to 10 with my mac) However I could give MAMP a go as a point of difference!!

    DionDesigns

    (@diondesigns)

    Look in your wp-config.php file and make sure the host is this:

    define('DB_HOST', '127.0.0.1');

    and not defined as ‘localhost’. This seemingly minor thing can make a huge difference in MySQL performance on localhost installs.

    leejosepho

    (@leejosepho)

    @diondesigns: Can that also be used at a regular server where I have a Dedicated IP Address?

    DionDesigns

    (@diondesigns)

    You might see a slight improvement in server performance; it’s certainly worth trying. You can always return the setting to ‘localhost’ if ‘127.0.0.1’ causes any sort of problem (which is possible if MySQL was not configured properly).

    To those reading…hardcoding the localhost IP address will allow MySQL to bypass resolving the ‘localhost’ domain. This is not a big deal on servers with BIND or other DNS software installed, but it’s a performance bottleneck with localhost installs.

    Eddie_E

    (@eddie_e)

    Unfortunately this didn’t work for me… same delay… It’s only on front end, admin runs how it should!! Tried MAMP also and cant seem to get this to even work with the database even when I know all the settings are correct… I may have to just deal with the delay unless there are any other possible solutions?

    LyleChamney

    (@lylechamney)

    Tried MAMP also and cant seem to get this to even work with the database even when I know all the settings are correct.

    Were you getting the database connection error?

    even when I know all the settings are correct

    Unlike XAMPP, where it is empty, with MAMP the default database user password is root

    I successfully use MAMP on my Macs and have done so for a number of years. There may be some other issue that is not related to a local server that is causing this slow down. Can’t think of what at the moment though 🙁

    Eddie_E

    (@eddie_e)

    I didn’t change anything for MAMP, it gave me 8888 as a port so was different to my 8080 with XAMPP so no conflicts, I was able to upload my database to phymyadmin correctly but then it just wouldn’t connect… I’ve completed loads of wordpress sites on XAMPP so I know how to get them to work… A quick goggle search suggest I’m not the only one with this issue with WAMP. For now I’ve just decided to skip the localhost for this particular job… Ive spent 4 hours today trying to solve this… I have just set up dreamweaver to auto upload saved files to my online server and will just work through this!

    All this happened because I upgraded my XAMPP.. annoying!

    Hi Guys, I experienced similar issue when I downloaded my online website and ran it on WAMPSERVER locally. After to configure the website, all local page request was taking so much time load.

    I installed the Fiddler application to monitor my network traffic and I could see that the delay are being caused by requests to ssl.gstatic.com and fonts.googlesapi.com. These request are taking so much time and the page did not loaded until there.

    I added these two host on my windows host file point it to localhost
    localhost ssl.gstatic.com
    localhost fonts.googlesapi.com

    This fixed my issue.

    Thanks for your response… I’ll try this on my next project

    @diondesigns Ty! i just installed xampp and wordpress locally as a fresh install and it was running so slow i kept getting the 30 second timeout on any page i went to, even the install timed out. ur solution changing localhost to 127.0.0.1 in the wpconfig file worked. now it loads almost instantly. Thx!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘localhost site running very slow on a XAMPP installation’ is closed to new replies.